Can't choose Media Servers

I got a new Plus last Saturday and upgraded to latest firmware.  Have been using it all week accessing the media server on my DNS-321 and Win 7 PC.   All of the sudden today, when I click on the “media server” icon in the Plus Video menu, I get nothing.  It will do absolutely nothing if I hit press enter or if I hit the right arrow key.

I have reset the box and restarted my servers.  Nothing.  I can however access the network shares on both the DNS-321 and the Win 7 PC.

Also, I have a non Plus WDTV Live in another room and it is accessing everything fine.

Any clues?

I really didn’t think this was a network issue since I (a) got a “Media Server” icon, and (2) could access the NAS through Network Shares.

Anyway for grins, I decided to try acces wirelessly.  It worked.  I then plugged my powerline adapter back in and it also worked.  Go figure.  I’d gone through everything including resets and rolling back the firmware with no luck.

Janry… The NAS devices need to have their media servers running also. I am using 2 Zyxel NSA. One has its media server running and the other does not. Only one appears in the Media Server screen on the WD. cj

cjeman wrote:

The NAS devices need to have their media servers running also.


That was not the issue.  As I said, the non plus WDTV Live could access my media servers fine while this was happening.

It happened again.   I guess the plus just doesn’t like my powerline adapters.  That and the ever changing HDMI settings made me re-think my set-up.   The easy solution is to swap my two WDTV Live units.   I moved the non plus to where plus was and the plus to where the non plus was.   That’s better because I get a reliable wireless n connection where I now have the plus and it is is connected to my bedroom TV which is 720P.

The non plus is performing well over the powerline adapter and maintains the 1080P setting. 

Win. Win.

The only down side is I the non plus doesn’t work with Netflex but I wasn’t planning on using Netflex anytime soon anyway but if that changes, I guess I’ll have to get a Boxee.

Sure isn’t solved so far as I’m concerned.  Worked fine for many months but now under Music/Media Servers I get nothing.  Tried reset, reboot, factory defaults.  AND everything in “Solved” link.  Any other ideas?


Do you actually see the media server icon?  Or, I should ask:  if you see the media server icon, what happens when you click on it?

How are you connected to the network?