Can't change RAID on WB MyBook Studio 2 on Mac OS X Mojave

#1

I have two WD My Book Studio 2 drives. Both set up as RAID1 a long time ago. I want to reset one of them to RAID0. I installed the WD RAID Manager on my computer running Mac OS X Mojave.

After rebooting I see the WD icon in the toolbar. I can click on it and select WD RAID Manager which opens to show the attached drives.

After changing the RAID level, I click confirm and enter admin credentials as required. Then the application just sits there with a multicolored wheel spinning away forever. Nothing changes on the drive and I have to reboot the Mac to get back to the WD RAID Manager.

The same thing happens with both drives. I even tried changing the RAID level via my MacBook but get the same behavior.

These are Firewire / USB drives and I tried the process connecting them via both interfaces. Nothing,

#2

Hi neil68,

Run a First-aid scan on the drive using the Disk utility of your Mac OS X Mojave. It should fix corrupt parts on the partition if there is any. Also try to uninstall and install the application again. This software is one of the end of life software and there are no new updates present for this particular software. The last update this software received was for Mac OS X 10.9 (Mavericks). If after all of this the issue still persists then it’s possible that the WD Drive manager software is not compatible with the Mac OS X Mojave. You can always try to use this software with an older version of Mac OS and check if you are able to change the RAID then. To install WD Drive Manager and set the RAID mode on a Mac refer to the link below: