Can't backup to My passport 3TB today on High Sierra, but it worked yesterday

I have a 2015 Macbook Air running High Sierra 10.13.6. Yesterday I successfully backed up through Time Machine to my “My Passport”. But when I closed my laptop, the light on the drive was still blinking, and I thoughtlessly pulled the USB out.

Today, it still flashes, but it won’t back up at all. There was incomplete backup document in the drive folder, so I tried deleting it. But that didn’t help; maybe made things worse actually

I don’t know how to fix this. I see others having problems with High Sierra and this brand of external drive, but mine was working yesterday.

Any suggestions

Hi Carizma22,

Have you reformat this drive in macOS extended file format? If not, then please first format the drive in macOS extended and then try to backup again. And always eject the drive before unplugging it.

You can refer this article for reference:

Thanks for the suggestion. I don’t understand why I need to reformat the drive in MacOS extended format if it is a MacOS dedicated hard drive “MY Passport for Mac.” Is it because it has failed, or is this something you always do to a hard drive. I am concerned about reformatting it and losing everything that is already on it.

Dear Clara:

I tried to do that, but when nothing happened after I clicked n erase, I checked online to see how long it would take and all the reports said several days because It is 3TB. Is that right? I have to quit the procedure.



I have essentially the same problem. My OS is High Sierra 10.13.6, and the first thing I did was to use Disk Utility to erase my newly purchased 2Tb My Passport drive, then format it as a Mac (Journaled) drive. Then I partitioned the drive (1.2 - 0.8), then ran Time Machine to save a backup from my MacBook Pro to the 1.2 Tb partition, which I’d named MacBook_Pro. The next time I tried to run time machine it gave me an error message that reads “Time Machine couldn’t complete the backup to MacBook_Pro. An error occurred while copying files. The problem may be temporary. If the problem persists, use Disk Utility to repair your backup disk.” I ran Disk Utility and it says the drive is fine. I used the Command Line to repeat that test, and it too says the disk is fine. I used the command line to try to force a backup, and got the same error message. So I erased the drive completely, twice, renamed the entire drive, erased it again, re-addressed Time Machine, and again got the same message. Then I copied and pasted a reasonably large folder manually (using Finder) and it copied just fine onto the My Passport drive. But Time Machine won’t work. Can anyone suggest a cure?