Can't Backup from EX2100 to USB after upgrade to 2.10.X

I was running 1.06.133 (I think) on my EX2100 and everything was running great. I could backup from the NAS to a My Book, something I could never do with a My Cloud or My Cloud Mirror. Then I got lulled to sleep and thought all was well…then I upgraded to v2 and it all went to H3LL. Backups would never get past about 800Mb and the progress thermometer would freeze. I let it run for a couple of days and nothing updated but the drive stopped backing up.

I found My_Cloud_EX2100_1.06.133.bin and downgraded the firmware and then noticed that my Cloud Devices said 0 instead of 3 and the Apps said 0 instead of 4. OK, so I tried to add my devices back to cloud access and the EX2100 says I don’t have permission even though it shows me as the admin.

Any thoughts on regaining control of my EX2100? Hold the reset button for 45 seconds?


I recommend you contact WD support for assistance with this.

Contact WD

I did a couple of weeks ago when I had backup issues with v2.x. No response and I have a direct connection to Level 2.

I think the cloud issue is a known issue. I remember reading that WD changed some things so only v2.x works with cloud access. So, seems I am stuck choosing between cloud access and NAS to USB backups…

I received a call this morning from Level 2. What we discovered, new to WD as well, is that NAS to USB backup jobs that were created in v1.x firmware CANNOT be understood by v2.x firmware. Putty showed that the job never starts even though the dashboard says it is running. That is why it never completes.

The solution was to create new backup jobs and have them go to a new folder on the USB drive. So, now, apparently, I can use cloud access and do backups.

The other interesting discovery is that v2.x uses a lot more of the CPU and memory resources than v1.x. So, back ups and other resource intensive processes have a greater chance of creating issues.

Not so fast. The first backup worked but that was initiated by WD support and they had used Putty to turn off some services. After disconnecting, I tried to run the next NAS to USB backup and it failed just like before at 800Mb.

OS3 (v2.x) must be a resource hog such that even the EX2100 doesn’t have enough CPU or memory to do simple tasks…did they hire MS bloatware engineers?

UPDATE: Level 2 support called back today and verified that you can copy and paste data from the EX2100 to the My Book but, at least for some Shares, you cannot do a NAS to USB backup. This proves that the backup code has bugs. Now they have to go figure out how to fix it.