Can't access WD Elements portable 1T


I’m using ASUS Laptop, Win 7.

I don’t see the drive in “My Computer”. I see him in the “Devices Manager” with the yellow ___mark on it. I tried and “fix the problem” doesnt work and I can’t even remov it. Also tried to “check for updates” on the device and also- didnt work.

It does work on other computers with no problems at all (using the same usb cable).

I REALLY dont want to formate it (-I have alot of important documents and files in it).

I really would like to get some help.




No need to reformat the drive. Sounds like you are experiencing a drivers issue. 

Make sure that all the drivers for the USB ports are properly installed. If possible, uninstall the drivers and install that again.

Please note that the WD Elements is a plug and play drive and it uses the drivers for the use ports of your computer.


First, thanks for your respond!

Now- I tried to uninstall and it keeps telling me that there are some problem with the “Device Manager” (something).

Also- I tried to download an update for my devices-manager from the microsoft site and couldnt… I think I have a problem with the windows updates… I hope I’ll figure it out… :\

Thanks again.