Can't access USB drive

I searched the forum and found several similar topics, but trying to follow the advice given there did not resolve my issue.

I cannot access an NTFS disk on MyCloud. 3 days ago in mounted fine and it still can be mounted on my laptop or e.g. my router. I tried running chkdsk on the drive in Windows, safely disconnecting it, rebooting MyCloud and then reconnecting the drive to it. I also tried renaming the drive and cleaning the mount table.

I have MyCloud, with firmware version v04.05.00-315. When I connect the drive, I get this in :

2017-06-12T16:51:24.904667+02:00 di=v7bT37nXku info logger: INFO: Device added: device=1, vendor=Samsung STORY Station 3, model=Samsung STORY Station 3, serial_number=000000000000011E094C, revision=1.00
2017-06-12T16:51:33.294563+02:00 di=v7bT37nXku info logger: INFO: Mode sense to Power condition page failed on Samsung STORY Station 3 Samsung STORY Station 3
2017-06-12T16:51:34.967442+02:00 di=v7bT37nXku info logger: INFO: attached USB partition, reduce inotify limit to: 20000
2017-06-12T16:51:44.770938+02:00 di=v7bT37nXku info logger: Zalt
2017-06-12T16:51:45.442592+02:00 di=v7bT37nXku err logger: ERR: Exception creating share Zalt - exception 'Shares\Exception' with message ' call failed. Returned with 127' in /var/www/rest-api/api/Shares/src/Shares/Model/Share/Listener/Linux/ShareListener.php:25
Stack trace:
#0 /var/www/rest-api/api/Shares/src/Shares/Model/Share/SharesDao.php(67): Shares\Model\Share\Listener\Linux\ShareListener->shareAdded(Object(Shares\Model\Share\Share))
#1 /var/www/rest-api/api/Shares/src/Shares/Model/Share/SharesDao.php(174): Shares\Model\Share\SharesDao->notifyShareListeners(1, Object(Shares\Model\Share\Share))
#2 /usr/local/sbin/wdAutoMountBridge.php(73): Shares\Model\Share\SharesDao->add(Object(Shares\Model\Share\Share))
#3 {main}
2017-06-12T16:51:45.958028+02:00 di=v7bT37nXku err logger: ERR: wdAutoMountLib: /usr/bin/php /usr/local/sbin/wdAutoMountBridge.php createShare Zalt  true any 2 2000396.288 false 1 ntfs, status 768
2017-06-12T16:51:46.014981+02:00 di=v7bT37nXku err logger: ERR: create share failure Zalt, error 768
2017-06-12T16:51:48.660020+02:00 di=v7bT37nXku err logger: ERR: Exception deleting share Zalt - exception 'Shares\Exception' with message ' call failed. Returned with 127' in /var/www/rest-api/api/Shares/src/Shares/Model/Share/Listener/Linux/ShareListener.php:139
Stack trace:
#0 /var/www/rest-api/api/Shares/src/Shares/Model/Share/SharesDao.php(75): Shares\Model\Share\Listener\Linux\ShareListener->shareDeleted(Object(Shares\Model\Share\Share))
#1 /var/www/rest-api/api/Shares/src/Shares/Model/Share/SharesDao.php(213): Shares\Model\Share\SharesDao->notifyShareListeners(3, Object(Shares\Model\Share\Share))
#2 /usr/local/sbin/wdAutoMountBridge.php(92): Shares\Model\Share\SharesDao->delete('Zalt')
#3 {main}
2017-06-12T16:51:48.849556+02:00 di=v7bT37nXku err logger: ERR: wdAutoMountLib: /usr/bin/php /usr/local/sbin/wdAutoMountBridge.php deleteShare Zalt, status 768`

and in cat /var/log/messages:

2017-06-12T16:49:02.450581+02:00 di=v7bT37nXku info kernel:[   99.454001] EXT4-fs (sda4): barriers disabled
2017-06-12T16:49:03.351395+02:00 di=v7bT37nXku warning kernel:[  100.350873] EXT4-fs (sda4): warning: mounting fs with errors, running e2fsck is recommended
2017-06-12T16:49:03.485770+02:00 di=v7bT37nXku info kernel:[  100.481586] EXT4-fs (sda4): mounted filesystem with writeback data mode. Opts: acl,user_xattr,data=writeback,barrier=0,init_itable=10
2017-06-12T16:49:03.572443+02:00 di=v7bT37nXku info kernel:[  100.572741] EXT4-fs (sda4): re-mounted. Opts: user_xattr,barrier=0,data=writeback
2017-06-12T16:49:16.999032+02:00 di=v7bT37nXku info kernel:[  113.997962] Adding 500672k swap on /dev/sda3.  Priority:-1 extents:1 across:500672k
2017-06-12T16:51:21.868829+02:00 di=v7bT37nXku info kernel:[  238.886828] usb 2-1: new SuperSpeed USB device number 2 using xhci-hcd
2017-06-12T16:51:21.901115+02:00 di=v7bT37nXku info kernel:[  238.928928] usb 2-1: New USB device found, idVendor=04e8, idProduct=6054
2017-06-12T16:51:21.915011+02:00 di=v7bT37nXku info kernel:[  238.935671] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
2017-06-12T16:51:21.915059+02:00 di=v7bT37nXku info kernel:[  238.942882] usb 2-1: Product: Samsung STORY Station 3
2017-06-12T16:51:21.920097+02:00 di=v7bT37nXku info kernel:[  238.947984] usb 2-1: Manufacturer: Samsung STORY Station 3
2017-06-12T16:51:21.930914+02:00 di=v7bT37nXku info kernel:[  238.953509] usb 2-1: SerialNumber: 000000000000011E094C
2017-06-12T16:51:21.969135+02:00 di=v7bT37nXku info kernel:[  238.993109] scsi2 : usb-storage 2-1:1.0
2017-06-12T16:51:31.376033+02:00 di=v7bT37nXku notice kernel:[  248.231232] scsi 2:0:0:0: Direct-Access     Samsung  STORY Station 3  1AQ1 PQ: 0 ANSI: 0
2017-06-12T16:51:31.376241+02:00 di=v7bT37nXku notice kernel:[  248.240191] sd 2:0:0:0: Attached scsi generic sg1 type 0
2017-06-12T16:51:31.376260+02:00 di=v7bT37nXku notice kernel:[  248.246121] sd 2:0:0:0: [sdb] 3907029168 512-byte logical blocks: (2.00 TB/1.81 TiB)
2017-06-12T16:51:31.376274+02:00 di=v7bT37nXku notice kernel:[  248.254391] sd 2:0:0:0: [sdb] Write Protect is off
2017-06-12T16:51:31.376346+02:00 di=v7bT37nXku info kernel:[  248.302282]  sdb: sdb1
2017-06-12T16:51:31.376384+02:00 di=v7bT37nXku notice kernel:[  248.318382] sd 2:0:0:0: [sdb] Attached SCSI disk

(Apparently the main MyCloud drive has errors, but I am not sure how to fix it neither.)
and in mount -l:

/dev/root on / type ext3 (rw,relatime,errors=continue,user_xattr,acl,barrier=1,data=ordered)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=40960k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=40960k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev type tmpfs (rw,relatime,size=10240k,mode=755)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /tmp type tmpfs (rw,relatime,size=102400k,nr_inodes=20480)
/dev/root on /var/log.hdd type ext3 (rw,relatime,errors=continue,user_xattr,acl,barrier=1,data=ordered)
ramlog-tmpfs on /var/log type tmpfs (rw,relatime,size=40960k)
/dev/sda4 on /DataVolume type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /CacheVolume type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Ludwik type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/TimeMachineBackup type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
/dev/sdb1 on /nfs/Zalt type ufsd (rw,relatime,nls=utf8,uid=65534,gid=1000,fmask=0,dmask=0,force,user_xattr) [Zalt]

So the drive is mounted as /nfs/Zalt. However in the web management tool I have this message about the USB drive:

USB Device Details
USB Device Name Samsung STORY Station 3 Samsung STORY Station 3
Manufacturer Samsung STORY Station 3
Model Samsung STORY Station 3
Serial Number [Deleted]
Firmware Version 1.00
Size 0 KB

and the network share Zalt is not available.

Any help would be appreciated!

Did you notice that warning message? and Did you try running e2fsck?

Please update your question with that information.

This is the main MyCloud disk, not the USB disk I am trying to connect. I tried, but I am not sure if it is safe to unmount this disk, since it is the main disk, so probably the one on which the system is running. Do you know if it is ok to unmount it?

Also, do you think it might be related to mounting another drive?