Cant access pictures on mac

I try to log in and then get hit with…

1.Make sure your device is powered on and connect to a network with internet access.

I have my cloud hooked up with a ethernet cable running right to the routers. I have even tried to hit the reset button.

  1. Update the My Cloud firemware. Youll need to do this from the dashboard (web interface) under settings

When i hit settings it says my cloud is offline. When checking all of this the light is blue, not blinking blue or anything else.

*Not sure if this matters but i am on a mac with the os of catalina. I am currently trying to downgrade back to mojave. I know catalina has been acting up with some of my other programs as well.

What are you logging into to? MyCloud.com, the remote access web portal, or wdmycloud.local, the My Cloud Dashboard?

The MyCloud.com web portal has had issues for several weeks now where users may receive a message similar to the one you posted. First troubleshooting step is to ensure Remote Access/Cloud Access is enabled in the My Cloud Dashboard > Settings page and that it’s status indicates a connection.

Next, if there is a connection then try selecting the Gear icon to the left of the My Cloud name after you have logged into the MyCloud.com web portal. By clicking the Gear icon it will bring up a list of devices one can access remotely. See if there is an entry that does not indicate “offline”, select it and see if you can connect.

I am logging into mycloud.com. Im not sure where i can find the dashboard. Also when i do click the gear icon an see my device that says offline, i click it and it does nothing.

How to access the Dashboard on a My Cloud (single bay) device
https://support-en.wd.com/app/answers/detail/a_id/15104

Using a computer that is connected to the same network as the My Cloud device, launch a web browser
Enter either the name (or IP Address ) of the My Cloud device into the URL field of the web browser. For example:
Windows: http://wdmycloud/
Mac OSX: http://wdmycloud.local/

mycloud.local assumes that avahi on the MyCloud is working/responding. If you have set a LAN domain name on your router (which you should do) and have NOT used “local” as that domain name (which you should not do), then you can use http://mycloud.domain from Windows or Mac. For example http://mycloud.home, if “home” is your LAN domain name.