Can't access passport attached to WD MyCloud....etc

I recently purchased a Samsung smart TV. I have the WD MyCloud attached to it as well as a 4 TB WD passport hard drive. It worked well, for awhile. A new update for the smart TV appeared and was downloaded. Now I can’t see the passport that is attached to the Mycloud on my TV. I can see the passport when I go to the MyCloud app on my iphone and ipad. I was going to shut down the MyCloud. Now, for some reason I can’t even access the dashboard on any of my computers. When I attempt to open the dashboard, it stalls and when I try again it says it “can’t connect to the server”. I couldn’t access the passport when I first set up the cloud, so i went to the dashboard to try to shut it down and that seemed to do the trick, as the passport appeared. Did the TV update mess me up?

I have done quite a bit of research on this…the light is blue, etc…but I don’t see a solution anywhere. Granted, I am also not the most technically advanced person…so if anyone can help with this, I would greatly appreciate it


Hi DDubbs64, welcome to the WD Community. Have you tried pressing the reset button on the back of the My Cloud for 4 seconds? If the problem continues, try connecting the My Cloud Ethernet cable directly to the PC and verify if you can access the dashboard from there.