Can't access Network Shares on my PC or NAS (WD TV Live Hub)

WD TV Live Hub: I can’t access Network Shares on my PC or NAS. I am running Windows 7 64-bit Ultimate.

The Hub can read my Shared external drive for music (attached to my PC), but can’t read the GoFlex Home NAS nor the external drive: I have tried connecting the external drive to the NAS with only 6 folders visible using UPNP and no connection using Network shares.  I then connected the external drive to my PC and shared the drive, but I can’t connect via Network Share and selecting my PC. My PC shows up on the menu, but it keeps asking me for passwords: I have tried my windows password, router password, choosing “do not protect with login”, nothing works!)

I am getting very frustrated.  This system used to work before I moved and had to change to Time Warner cable internet. I also had to change to a Belkin N650 DB router and Belkin VideoLink 3 Powerline Internet Adapter (F5D4081) to save running wires or using the weak wireless system.  The F5D4081 seems to be fine: fast downloads.

Does anyone know whether I have a router problem, adapter problem, or WD TV Live Hub dying?  Or how to trouble-shoot to eliminate the problem?

NOTE: I have plugged the NAS directly into the router with no change, so I assume I can rule out the wall adapter.

It sounds like the issue maybe the router, as that’s the only real component that could cause issues.

On that note though, do files work the other way, as in streaming to your PC from the Hub.

I would do a reset from the Menu, sometimes the Hub gets confused.

Edit : Your new ISP has not given you any new AV/Firewall software has it? Try disabling firewall to aid diagnosis.

Yes, I can stream from the HUB to my PC and also from the NAS to the PC: the HUB is not able to access them (except the primary NAS thru UPNP.)  Yes, I reset the HUB with no improvement.  I have NIS 2012, but I check the devices and they are listed as “Shared” under Norton.

To support your theory about the router, I will occasionally get a Belkin Router error from the Router Management software - real brief, and often doesn’t affect downloads.

I found a list of routers compatible with the HUB.  (I need to keep wireless capabilities for our iPhones and laptops, but primarily use the ports.)  Should I consider router compatibility with the Seagate GoFlex NAS or should that not be an issue?

Mmmm unsure.

I see you have created another thread about this as I tried searching Google.

Might be worth speaking to the Goflex people, but if it all worked before I can’t see what has changed, did you have any issues setting it all up before you changed ISP/Kit, as in first setup ?

edit : Ah just seen you already have opened a message on Seagate :slight_smile:


Now I am getting really confused.

I ordered a new router, listed as WD TV Live Hub compatible.  I’ll let you know the results.

Well, the new Belkin router arrived  (N300 Wireless), and I was able to access my NAS!  I found the router listed under the confirmed compatibile routers: 

Frustration ended!