Can't access MyCloud on anything but PC since update

Hi. I have a MyCloud on my home network and it worked with no problems. I could access media on it from any device, like my smart TV, Xbox and PS4/5. I updated the OS to 5.x recently and now only my PC can see the device.

I’m sure a setting just needs to be turned on or off, but I just can’t find it. Can anyone assist me with this?


Edit: I just checked and it says indexing 4%, it’s been 8 hours since it started. Could that have something to do with my issue?

@bmbougie please check the following article. You’ll want to wait until Indexing has completed 100% before installing the Twonky Media Server App.

29985 My Cloud OS 5: TV, Printers, Scanners, IP Camera and Media Players Cannot Connect

I didn’t know I had to install something else, don’t remember ever doing that before. Must be because of the update? I’ll check out the article and come back if I still have issues. Thanks.

I had a similar issue where I wasn’t able to access my shared folders from a Xiaomi Mi Box (android). I could see the folders from my TV, and from my laptop, but not the Android box. I messed around with creating and re-creating shares etc and nothing seemed to work. Then just this morning I was playing around on Twonky again and I noticed that on the list of devices, there were two entries for it. I think I may have renamed it. So, I unticked the access to one of them, unshared and then re-shared the folders again and suddenly everything was back again.

I do still have to manually add the shared folders back into Kodi on my Android box, but they work fine now.

That may or may not help, but it’s what worked for me.

Twonky is some sort of software on the device, right? How do I access it?

Why does indexing take so long? It’s still doing it now!

Now I can’t even access the MyCloud from my PC. ANy suggestions?