Can't Access MyBookLive, Is There Any Hope?

I have a 1TB MBL that is about 4 years old. I’ve had it hooked up to my router(s) and it has worked fine over the years until recently. I used it primarily for backing up my Windows laptop and rarely accessed any files from it. A few weeks ago I started getting error messages on my laptop saying there was a problem with the hard drive. It was a warning sign so I made sure to perform a backup to the MBL and I also copied all of my music, pictures and videos into a dedicated folder with just those files. The laptop died shortly after and in the meantime I replaced it with a MacBook Pro.

I got the new MacBook Pro home and started setting it up… got to the point of connecting it to the MBL and here’s where it gets weird! I got to the UI login screen, typed in the password that I’m 100% sure was correct and it didn’t login. I tried a few other passwords and it gave me a “wrong password” error message every time. It did not show that message when I typed in what I believed to be the correct password, it just wouldn’t login. I tried to login remotely through the app on my phone and on the my cloud website (which I hadn’t done in a LONG time) and it said I couldn’t login that way until I updated the firmware on the MBL. But I couldn’t login to the MBL to update the firmware…

I went online and discovered the “reset” method using the button on the back. This is when I realized the LED on the front of the MBL was no longer working. At this point, the MBL can be heard powering on, it’s showing up in my router info screen with an IP address and all seems well other than the fact that I can’t login to the UI. So I try to reset it by holding the button for 4 seconds, no change… everything is exactly the same. I do some more research online, come up with nothing and end up trying the reset button again but for about 30 seconds this time. The LED is not working so the only way I can tell it’s doing something is by listening. When I held the button longer this time it sounded like it reset/rebooted so I thought my problem was solved. It was supposed to restore the factory network settings and I should’ve been able to get to the UI without a password. But… now it will not connect to the network. It’s still plugged into the router and can be heard booting up but the router never assigns it an IP address and I can’t find it anywhere on the network! I have the WD Setup software downloaded to the MacBook but obviously it doesn’t find the MBL when scanning the network.

I have read everything I can find online about this product and can’t find a single issue like this. Can anyone offer any advice? I’ve seen the posts about sending it to a data recovery company for $$$ or about tearing it apart and trying to get the data off of it myself but I don’t know if that’s what I need to do. My main concern here is that I don’t want to lose all of the family pictures saved to the MBL, going back to before my kids were born all the way up to our recent vacation this year. It doesn’t seem like it would just crash all of a sudden, seems more like it’s a networking problem or something simple that I’m just overlooking here… Can anyone help me out or offer any suggestions?

Thanks,
Joe

Hello,

seems like the unit might be defective, however i recommend contacting support to see if you can get more help regarding this: