Can't access my WiFi after installing WDMycloud


I recently bought and installed a 4TB WD Mycloud. To begin with everything was fine. I spent a couple of days transferring files from my various other sources onto the new NAS. During the file transfers I noticed issues connecting to my WiFi but thought it must be down to a bandwidth problem.

Since getting my files onto the drive however, none of my mobile devices can connect to my WiFi. 

I have no idea why this could be. I have been trying to resolve the issue for a number of hours now with no success. Any help/insight would be appreciated. I can provide specific system info if you need it. The basics are: Windows 7 Ultimate 64-bit; Virgin Media Superhub; WD MyCloud 4TB; HTC One; Tesco Hudl2

Are you using static IP’s?  Try setting the My Clound to a static IP address.  Use an address near the end

of the valid dynamic addresses or you could use one that is out of the dynamic range.

i.e. or


  1. Can the devices see your router’s WiFi signal: does it appear as an available network? Is there a decent signal strength? If you don’t see your network, reboot your router.

  2. If you can see the network, and you hit ‘connect’, what happens? What are sequence of status messages you get (it should be ‘connecting/authenticating/[obtaining IP address]/connected’)? 

  3. If you don’t get a ‘connected’ status, check that your router hasn’t forgotten its password for some reason (it’s likely to give an authentication failure if this has happened). Have you changed your router access password from the default? It may have reverted to the default.

  4. If you unplug the MyCloud from the router, do you regain WiFi access? (Disconnecting will cause the MyCloud to re-boot: don’t worry, nothing terrible will happen.)

  5. Try ‘forget network’ for your router on your android devices, re-scan for networks, then try connecting again, with the WiFi password.

  6. Use Wifi Analyser to see what your wireless environment looks like.

Some things to try. It’s almost certainly some config issue, but there’s a slim chance that something is faulty, and jamming the WiFi channel

IP addresses are a possible problem, but I can’t see that the MyCloud can have taken both of the addresses of the mobile devices, and, unless the OP has fixed them, they’re likely to be dynamic, allocated by the router’s DHCP server (the [obtaining IP address] phase in the connection sequence I described; I showed it as [optional], as it may not happen if the address has been fixed).

I didn’t mention this before but devices tend to always get the same dynamic IP address.  What can

disrupt this is when a new device is added to the network grabs a previously used address.  Then you

get a message that the address is in use when you power up the device that had that address in the past.

This is why I use static IP addresses for almost all of my devices.  I have something like 13 devices that need

IP addresses.  It was a pain when I would get the address in use message.  Not sure if that is the exact wording

since I have not seen that error in years.


Ok here goes:

  1. All the devices (my wife’s Samsung S4 also) can find the network. All register the signal strength as excellent.

  2. When connect is used the devices try to establish a connection but revert to the “saved, secured with WPA/WPA2”. After it has attempted to do this a few times the message changes to “Authentication Problem”.

  3. I have Reset/Rebooted the router. Reset the passphrase. Forgotten the details on the various devices and then re-input them.

  4. I have shutdown the MyCloud (no change). I have unplugged it from the router (no change)

  5. My WiFi analyser is reading my network at -40 dBm.

I am going a bit mental here!

It took me awhile to find this as I did not remember the search criteria “wifi cloud”?, so I had to page backward until I finally found it.

Scroll down to the bottom…

Hopefully it might be the solution that you need. 

When connect is used the devices try to establish a connection but revert to the “saved, secured with WPA/WPA2”. After it has attempted to do this a few times the message changes to “Authentication Problem”.

That suggests you (or the router) have the wrong password or the wrong protocol; it has saved the password, and says the link is encrypted with WPA/WPA2. The fact that you are getting ‘Authentication Problem’ points to a problem with, well, authentication…

The fact that removing the MyCloud from the router makes no difference points to it not being an ongoing problem caused by the MyCloud.

I’d have a careful look at the router settings. Are you sure that no access time windows are set, or any other strange settings?  A factory restore of the router might be in order, but make a careful note of your network access ID and password (your Virgin Media account details, that is).  Or just contact Virgin customer support. And wait…

I don’t have a Virgin router, but mine has a ‘network view’, which shows what devices are connected to it (or have been), and what their IP address is, and the protocol used to establish an IP address. Find a similar page on your router, and check the IP addresses for the devices, and check what IP addresses your devices think they are using (Settings/Wifi/(three dot menu)/Advanced). You can usually get the router to ‘forget’ them all, and restart connections (after setting the connection protocol to DHCP). There’s usually an ‘allow all devices to connect automatically’ setting, or something similar.

I suspect the problem may be coincidental to getting your MyCloud, but it’s just possible that the MyCloud has used some router UPnP commands to try to establish a route out of your network (for cloud access), and this has messed up the router.

The other question then arises: which method did you use to set up your MyCloud?  The online setup, or just the Dashboard?  How are you accessing the MyCloud; WD Desktop and WD QuickView, or just mapped into your file system?

Thanks everyone for your suggestions.

In the end I went back to the most basic help instructions. I turned everything off, then turned it all back on.

No idea what was causing the problems but everything is working again.

I know this isn’t a great solution that others will be able to implement but it worked for me.

The only issue I have now is that my smart tv is only showing some of the folders on the drive. I have checked that the DLNA is enabled. I don’t understand why it shows some folders but not others. I guess I might have to move this thread to a new one to get the help I need.

Thanks again.

I just figured this problem out too. In case anyone needs to know, you have to set the media preference to on for each individual share. All working now and I’m very happy.