Can't access my Sharespace (4TB) via SSH


#1

I have tried to use FileZilla and WinScp to login with SFTP without success.

The Sharespace systemlog just shows me this message:

02/10 16:13:44 WDShareSpace auth.info sshd[23944]: subsystem request for sftp failed, subsystem not found
02/10 16:13:44 WDShareSpace auth.err sshd[23944]: error: subsystem: cannot stat /usr/sbin/sftp-server: No such file or directory
02/10 16:13:44 WDShareSpace auth.info sshd[23944]: subsystem request for sftp
02/10 16:13:44 WDShareSpace auth.info sshd[23942]: Accepted password for Testperson from 10.0.1.1 port 33687 ssh2
02/10 16:13:44 WDShareSpace auth.err sshd[23942]: error: Could not get shadow information for Testperson
02/10 16:13:35 WDShareSpace auth.info sshd[23940]: subsystem request for sftp failed, subsystem not found
02/10 16:13:35 WDShareSpace auth.err sshd[23940]: error: subsystem: cannot stat /usr/sbin/sftp-server: No such file or directory
02/10 16:13:35 WDShareSpace auth.info sshd[23940]: subsystem request for sftp
02/10 16:13:35 WDShareSpace auth.info sshd[23938]: Accepted password for Testperson from 10.0.1.1 port 39986 ssh2
02/10 16:13:35 WDShareSpace auth.err sshd[23938]: error: Could not get shadow information for Testperson

What am I doing wrong? Is there any wrong with my settings?

I have forwarded port 22 to my Sharespace but unfortunately the Sharespace is not logging me in  though my username and password is right.

 Please help me!


#2

I managed to SSH in as user root with the default password (listed on the webpage as welc0me - 0=zero).

I assume you enabled the use of ssh thru the web interfaces’ advance setting section.

Once in, I went looking for the sftp subsystem as listes in the “/etc/sshd_config” file and it is not where it should be.

~ $ cat /etc/sshd_config | grep -i sftp

Subsystem sftp /usr/sbin/sftp-server

~ $ find / | grep -i sftp-server

~ $ nada!

It’s not on my gizmo!

But when I searched differently I got this

~ $ find / | grep -i sftp

/etc/.factoryDefault/vsftpd.user_list

/etc/.factoryDefault/vsftpd.share_acl

/etc/.factoryDefault/vsftpd.share_acl.fail

/etc/.factoryDefault/vsftpd.conf

/etc/vsftpd.share_acl

/etc/vsftpd.conf

/etc/vsftpd.user_list

/sbin/vsftpd

/tmp/vsftpd.log

/tmp/.back_conf/vsftpd.share_acl

It uses “vsftpd” instead. Information is available at " http://vsftpd.beasts.org/". I don’t know it, I will read up on it. One thing is sure (on my WD box at least - no sftp available)

Good day.