Can't access my My Cloud

I have a My Cloud diskdrive which is less than a year old. Suddenly I can’t connect to it from any computer. It’s too bad since I have unique information on it. Blue LED is on without flashing, on the rear side the yellow LED is on and the green LED is flashing now and then. I have tried changing the Ethernet cable and also changed port on the router.
Any tips on how to save the data on the disk? Is it possible to use the USB-connection to reach data on the disk?

No you can’t use USB, only ethernet on MyCloud devices.

How are you trying to access it? Via Windows Explorer/Mac Finder, or via WD Quickview?

Also are you accessing it by name or by IP address? Or via shortcut?

It may be that your MyCloud has been getting its IP address via DHCP from your router, and that IP address may have changed. If you go to your router and look at its client list, can you see the MyCloud listed there? If so, if you enter that IP address in Windows Explorer as \\IPaddress (e.g. \\ or whatever) or the equivalent in Finder, can you access it that way?

Thanks! I found the new IP-address on my router and by using that I got contact with My Cloud. The problem is solved! Thanks again!

One thing you can do is if your router has a dhcp reservation. Is to reserve an IP address for the MY Cloud. That way it will always have the same IP address.