Can't access My Live Duo

Hi WD Community,

I’ve been having real problems accessing MYBOOK LIVE DUO. Can anyone help. My problems listed below:

  1. Access from remote location using web interface, I get the following message on ‘log in’ page -

Unable to restore: DYNAMICCONFIG, safe copy is truncated
Dynamic Config file was truncated, failed to restore it from safe copy

Note: I can still access the ‘public’ folder but cannot copy anything to any of the folders. Very slow and stops after a few Mbps.

  1. Access from smartphone (Android) using WD Photos app gives message - Unable to access device . (-1)

3. Access from smartphone using WD 2go gives message - Network connection failure (1000)

4. When at home, connected via LAN I cannot access the device using the drop down menu at top of computer screen as I previously did.

PLEASE NOTE: I’ve been using the WD apps and access to the server before with no issues apart from WD Phots disappearing over time. I have re-installed apps, clicked on and off ‘remote access’ on drive and restarted all the usual stuff.

Any ideas anyone?

When you say that you can access the public folder… Do you mean you can connect from your LAN but not from remote?

So far have not seen this error message

I think I know what the problem is.  There is a file of that name and it can get corrupted. For the people who have SSH enabled I’ve given ggidance on how to correct the syntax of each line in that configuration file and once done their MyBook Live’s (Not Duo) Dashboard UI came back to life.

So youy have SSH enabled on your Duo?


Thanks for your help. I found several posts relating to the SSH. Problem is I can’t access MBL at all.  Can’t access via WD Qucik View and can’t access via the browser http://129.25.676.30/ or http://mybooklive/ or

The only thing I can access is my ‘shared’ folder via the web (remote and LAN) and copy files into it but very very slowly (10hrs for 1GB).

Can you help? It’s been a very frustrating few weeks.


I think on the CD there is a utility called WD Link that will discover the LAN IP address?  I’m wondering if you’ve misconfigured the IP address settings in which you can use the reset button on the Duo that clears the owner password, resets the root password and sets the networking parameters to DHCP.  You’ll then need to sign-onto the router to see what IP address it has given the Duo and then use that LAN IP address to access the Duo on your network.

From what you’ve written I think that is the solution.

There was no ‘WD Link’ on the CD. I tried the reset button on MBLD, switched off power, removed network cable, tried various other ports on my router, restarted my computer etc etc and still no luck. I did manage to find the IP address from the CD but when trying to access with my browser it just shows a blank white page.

I can still see the device and acccess contents but just can’t get into the dashboard. I can’t think of any other way to get into the device. BTW — The green LED is constantly blinking even when all activity is stopped and connected devices removed. The only time it’s not is when I restart it and it’s then solid for a few seconds before it starts blinking again.

Do you think my device is faulty?

I have a feeling you’re looking to getting an RMA arranged.  Do you have stuff with a Microsoft operating system or do you have computers from the Apple stable?

I’m running with the Macintosh operating system OSX.

Right, this may explain things. On the My Book Live there have been reports of the Mac OS interacting with a software component on the My Book Live Duo which causes a log file to explode in size and fill-up the MBL’s system partition, which causes the gren LED to always flash, shuts down the RAMLOG service which only has 20Mb to play with causing logs to be written directly to disc and also with a full-yo-the-brim-with-data Linux system partition, the Web UI gets killed.

The MBLD should be recoverable if you have SSH enabled by creating a soft link so a particular log file is linked to Linux’s bit bucket.

Failing that, you may need to get in touch with Western Digital’s technical support and you might end-up having to RMA the drive, but if you do make sure it has the absolutly latest firmware which has a fix for this issue.

Search the MyBook Live forum for “CNID”.  The thread you’re looking for has many messages on this topic.

Myron, firstly thanks very much for you efforts in trying to resolve my issues but unfortunately I’ve come to the end of the line and patience as far as this is concerned. I cannot get into the drive so can’t enable SSH and do all the other things people suggest + most of the feedback I’ve read needs an IT expert to understand…it’s hardly consumer friendly.

The fact that not one WD support person has intervened (when many posts I’ve read do have) leaves me very dissapointed. It’s clear from the numerous posts under CNID that Mac users have had issues for a long time and yet nothing seems to be resolved. I bought a Buffalo NAS server, lower priced than the MBLD for my office and both PC and Mac users have been using it with 0 downtime for the past 6 months and we can access everything effortlsy on smartphones/i phones etc. It’s brilliant compared to this product.

Now I’m afraid that if I send it back it will take 3 months to get it fixed, and have my data restored…if I’m lucky! I live in Malaysia and these things always have to go back to some other country to be resolved.

I’m beginning to regret buying this product and can’t believe haven’t mad any great efforts to help Mac users.

Thanks again, you have done more than most would.