Can't access My Live Duo Interface

Ok, so after two months of use I couldn’t access my interface on MLBD and I tried ‘everything’. I’m using Snow Leopard on a Macbook Pro. I had lots of suggestions from community members…thank you… and called Technical Support but unfortunately no one could solve the issue so reluctantly I took the machine back to where I bought it and three weeks later I got a new one.

So before I set about copying over the many files I had stored in the first unit I though I’d better see if this one works. It doesn’t. I can only access via direct connection from Mac to the unit but not through the router so I cannot update the firmware. And, the new unit provided has the old firmware…doesn’t make sense to me.

I’m struggling here to justify this purchase…I see so many other people having the same issues. I installed a much cheaper Buffalo server in my office and it’s much much better…reliable, easy to use and faster. So why, is the MBLD such a troublesome unit and why aren’t WD trying to do something about it? It’s clearly got many issues.

Anyone from WD want to respond to this? You ignored my earlier posts for help.

A very frustrated customer.


I would check the router firewall in you case. You can also download the firmware from the WD web page and update it manually. Check the link below for the steps.

1 Like

Thanks - problem is now solved after restarting everything.