Can't access My Cloud via Network, My Cloud App, and Dashboard


I initially set up my EX2 at a different location which has different IP settings compared to the IP Settings at home. I can’t detect and access the EX2 at all. I also tried running the setup again but it won’t show up on my home network. I also tried resetting the device by pressing the reset button found at the back of the device but nothing happened. The IP Settings did not go back to the original settings.

Can anyone here help me out regarding this issue? Your help would be greatly appreciated.


Reset the device via the reset button

go to

download and install the software

Report back.

Hi! As mentioned in my original post, I already tried resetting the device through the reset button. Unfortunately, the device settings did not reset to factory settings.

You may need to hold the reset button down for up to 30-seconds.

I was able to setup my WD EX2 at work and take it home, run the software and it detects and works just fine. 

Are you on a Mac or PC? I know on a Mac it creates shortcut alias’ which have to be updated with the new IP.

Can you login to your router, checked attached devices and see the IP Address and go to it via a web browser?