Can't access My Cloud Mirror over a network

Hi, for almost four years I had no problem with accessing my My Cloud Mirror. But now I can’t. I tried:

  1. Enabled SMB 1.0.
  2. Changed settings on the dashboard (max SMB to 2, 1, tried other settings) (BTW dashboard works very very slowly).
  3. Installed the latest firmware (2.12.197).
  4. Installed a bunch of apps (WD Smartware, WD Access etc). Some of them can’t find My Cloud Mirror at all.

My Cloud Mirror has a static IP, I can access the dashboard. The LEDs on it seem to show it works as usual. 1 and 2 are light up, the topmost is slowly pulsating.

I can access SSH (although git stopped to work, but that might be related to a newer version of git/git extensions that I installed recently).

I have TPLink router (WR841N).

I tried accessing it from two Windows 10 computers and one Windows 8 computer. Doesn’t work on any of them.

Any suggestions what I can do to make it work?

When did you do that? Around the same time the problems begun?

It sounds to me like either you have a network issue generally, or possibly that the MCM’s processor is very busy doing something and so isn’t timely in responding to “doing the day job” of responding to access requests etc. An example of that could be if it’s busy talking to GitHub due to the changes made above perhaps. I’ve seen similar things happen when stuff like DLNA has been enabled (and the MCM does off and scans it’s HD for media) or the av add-on installed and activated (likewise scanning).

If it’s a network issue then you should see that generally when trying to access anything across it, but if it’s the CPU being busy then you can just wait for it to finish what it’s doing, or alternatively (as you do have dashboard access) go in and stop it doing whatever it’s doing and see if things pick up again.

The issues with accessing the WD begun before problems with git. I tried different things with WD and after a few days, for other reasons, I updated git extensions and that’s when I had problems with git.

Slowly pulsating LED indicates that it doesn’t do anything, right? The issue probably started a few months ago, I just didn’t have time to investigate it. I started looking into it last week and then I started to update stuff etc. I updated git extensions last saturday.

It’s not that I can’t access it now or then. It’s that I can’t access it at all (via file explorer).

A blue pulsing power LED means the drive is in standby mode (see page 8 of the MCM manual).

I would have expected trying to access it should wake it up again, but if it’s not then perhaps try a soft reset. See this page for the two reset options available (neither of which are data destructive).

But if it’s not being awoken properly by an access attempt, it may be that there is a wider problem either with the device or with the network access to it. It might be worth exchanging the LAN cable between the MCM and your router first to see if there’s a problem there for example.

MyCloud Mirror Gen2 Manual