Can't access mp3 and videofiles

Hey everybody,

I hope someone can help me with the following problem.

I own an n900, and i have a passport drive attaged.

On the drive are three folders:

1 photo

2 music

3 video

i can access all files on my pc (Windows 7)

On my tv, ipad and android phone, i can access the photos, but i cant access any mp3 files or videos

I can see them but i can’t open them ( nothing happens )

I tried to set the restrictions in all possible ways, but nothing changes.

When i added a usb drive to the n900 the same problems appear.

Thats why i concluded it has to do with the n900 settings.

Anybody any ideas what is going on?


If you map the USB memory connected to the my net on your computer, do you still get the same problem? 

Hey Alucardx23

I can easely access all the files from my PC, as long as i use the explorer and not use the sharename i entered in the wd n900

The TV, Android Phone and the Ipad, can’t access the video and mp3 files

The TV is Dlna certified ( Sony flatscreen)

Because it happens with the passport drive and the usb drive as wel , i think it is a bug or setting in the n900


I also have issues with the external WD drive connected to the USB of the N900 router where I cannot access video files through DLNA.  I can add files to one of the two shares of the device visible, but dlna apps do not recognize there being any video files.  I do not see any folders created though… I have a separate Iomega media drive and it has folders and an application to map drives to all the media folders… are we missing something? 

I actually got it to work by putting the external drive into USB port 2 instead of one… only problem now is that the router locks up now with the drive plugged into port 2 so I’ve abandoned the external drive on the router until the issue can be fixed.

I have the exact same setup, a N900, a Maxtor OneTouch attached via usb, and a SONY flat screen.  I have my folders setup the same way between graphics, music and video. My SONY smart TV seems to be able to see folders but unable to see any files.  I have a case entered with WD on this exact issue. We need to pursue this issue with WD as more than one person has the same setup with the exact same issues. On the consumer side this is duplicatable, so WD should be able to investigate, reproduce and resolve this issue.

My Sony BDP-580S blu-ray play would see all the files on my N900 with USB drive but refused to play any of them.  What ended up being the case for me was that while this router supports DLNA, it DOES NOT support DLNA conversion on the fly into a file format your other media devices can play.  This caused me to re-convert all my movies and music into m4p and mp3 (non-lossless and has to be 192 bit or less encoding).  This wasn’t an issue when I used my laptop as the DLNA server because win7 media center will auto convert files on the fly so I didn’t know this was a problem until using the USB ports on the router.

Because you said you are using a Sony TV, I would bet this is your problem as well with DLNA on the sony device but I cannot totally explain the lack of playback on other devices since I don’t have them.  If you check the super fine print and astricks/footnotes on your TV I would bet a lot that it says ONLY those 2 formats can be streamed to your Sony TV via DLNA servers.  Since the router cannot re-encode on the fly, thus failed playback.

Well, the thing is that i have the same issue when i try to playback on an android phone, and an ipad.

So  including my sony tv the files cannot be played on 3 regular devices. Seems odd to me.

I contacted wd support and they asked me all kinds of questions that i answered directly. The final response i had was of a kind that they do not read the things i wrote.

Very disappointing how they treat their customers.

To conclude: I bought a mybook live 1 tb and use this in stead of the usb drive. And the funny thing is: it works perfectly on all devices!

N900 router : nice device on paper, but not in use…

Advise: if you can choose… buy a different router


After another stupid question  ( Asking me things i allready provided ) i composed this mail.


I am sorry, i am no longer responding to your mails. I provided all the things you asked for already.

It looks like you are slowing things down. I think you have major issues witch you can’t resolve.

Probably the hardware is faulty and can’t be fixed by firmware.

I am very disappointed in the way you communicate and handle things.

I will start responding after you have read all my mails to you and info you allready have and you give me the information i need.


 As you see i am getting tired of having to answer questions without getting any answers.


You are not alone. I have experienced the same problem as reported  **Here **in this thread.

As you have explained, The problem is not seen with “Windows explorer” or WD TV Live series media players to some extent as long as you are at 1.04xx or  1.05.12  above but any other OS (I have tried Android Honeycomb OS as a test) and it fails to play any media type other than photos (JPG) as if someone decided at WD that - “what the heck” who would do that in Android OS? Just disable that option - Great! WD - You are wrong! - Please remember that the market to run on Android and IOS devices are in the millions of tablets and hand held devices - Guess what people do with those WiFi devices out there? - They connect to the router (or NAS share on the router) and try to gain access to the media as most of these devices have limited on device memory. and I am not alone.

To the community please make a note:  It is a " FIRMWARE" bug. I made WD customer support aware of this problem in the early weeks of OCT of 2012 and I was hoping to see a fix but so far no luck. I had provided screenshots, Logs, directory listings, explaining the issues in great detail as seen with Android, IOS and other media devices that attempt to gain access to the NAS shares that My Net N900 xx series provides. Only partial fixes were seen to get implemented in  1.05.12 for the storage router. So far only Windows PCs and  WD TV live streaming media boxes has access to Videos and Mp3 files.

IMHO, WD is new to Networking and It is sad to see that while their hardware is excellent (Much better than most other company’s product) it is the software / firmware which is cause for all probems. It is more of their QA department that is lacking experience. Someone in their QA department needs to get their acts together if they were to save their own product launch and their job and provide feedback to their developers who could code fixes for this problem. WD needs to have a broader test suites to validate a new firmware release out to the public as it is not only “Windows” that the end user uses these days. Wake up!

Please open a service ticket and submit your problems here: E-mail Support or  Phone Support

This is a community forum and none of the community members here can help you with this particular problem If we all take time to open a service ticket by email (IMHO Easier than posting on community forums and ranting about it) explaining this problem in detail I am postive that WD developers will get the attention and release the fix.

Having said, WD does read these posts you make here, but it takes a long time for them to get their attention, Please contact WD directly rather than posting in the community.

Best wishes


The mails i am reffering to are to and from the support desk.

I am astonished that they updated there firmware with non interesting features and small bugfixes, while there are major issues to adress.

And that the firmware they present is very buggy.

But this is the last i post about it, because i don’t want to look like a negative person because i am not like that.

I bought a Mybook live to access my files and that is working perfectly on all devices.

The N900 router… well… i never buy such a product from WD again. It will probably be replaced by a better Linksys

A shame because of the 7 Lan ports…


Anyone can download the firmware source code straight from WD…

With that said, I also agree that most if not all issues can be fixed through the firmware.  While I don’t know what firmware your androids and sony TV are running, my sony bdp-s580 blu-ray player and motorola photon has no issues reading/playing any files i have attached to my n900 as long as I have the files in the right types to be played back by the device.  This caused me to have to re-encode almost all of my movies (sonly only allows m4p’s/h.264 codec to be streamed via DLNA) and mp3’s (must be 192kbps or so for my android to play them), but they do indeed work now.