Can't access iTunes server on World Edition II from Mac


#1

Hi,

I’m having trouble accessing the iTunes server on my World Edition II. The iTunes server is enabled in the admin console, and iTunes on my Mac detects the server, but when I click on it in iTunes I get the error: The shared library is not responding (-3260). The firewall on my Mac is off, and AFAIK my router doesn’t block any ports on the internal LAN. Has anyone else run into this problem?


#2

For starters, what version of firmware are you running on the MBW II drive?

Please go to the user interface and click on advanced > Update > check for new firmware.

If you are running the latest version 01.01.18 that is the current release, if not please update the unit.

Once updated check your Mac and ensure that you have file and media sharing enabled on your Mac and ensure that the bonjour service is running.  Also what version of iTunes are you running?

Also you can try this.

Go into the media option of the MBW.  Click on iTunes and uncheck the enable service option.  Then go back to Media then Media Server > Twonky Media Settings.  Then click on maintenance.  Then click on Rebuild database.

Once the unit restarts, go back to the iTunes, recheck the enable service, and set for 30 min or 1 hour.  

You will need to wait for the database to completely rebuild and the drive to be completely scanned.  Depending upon the amount of music and data on the drive this may take some time to complete.

If the issue continues, please provide a little more info about your network.  The error  -3260 and iTunes is everywhere on the internet and is difficult to pin down.  This may also be a compatibility issue with some of your hardware in your network, however, please try the above and we will see if we cannot get you up and running


#3

I’m using My World Book 1 TB Network Storage and had issues with the iTunes and Media Server before I figured a couple of things out.

You can read below, but in short LOGIN TO YOUR Network Storage Device > Advance Settings > Media > AND ENABLE ITUNES SERVICES! Guaranteed, the issue will no longer be an issue!

Below may be helpful for other things, but real quick make sure you also put some music in your network storage public/music folder or else when you access itunes network server you won’t see anything.

First and foremost, I highly suggest a couple of things:

  • Login to your storage device through the web browser and make sure AFP is enabled, you will use this to access your device in a minute
  • Also, make sure the WORKGROUPS match on your storage device as well as your MAC, the workgroup can be changed on your mac by accessing SYSTEM PREFERENCES>NETWORK>ADVANCED>WINS> then make sure your workgroup matches what ever you set it to be on your storage device, be sure to apply the changes in the mac.
  • Connect your MAC to the storage device by going to FINDER>GO (on the tool bar)>CONNECT TO SERVER (on the bottom of the drop down)>and type in afp:// and the ip address you have assigned to it by your router. In my case, mine looks like afp://192.168.100.101/           You will be prompted for a username and password, its healthy to add it to your key chain unless you want to add it in every time you need to use it.
  • Also, repeat the step above for to set up your backup utility afp://192.168.100.101/wd_backup/ and use the wd_backup username and whatever password you have set up.
  • Once that is done, open a folder or drive and you should see your network storage…Browse to the /Public/Music/ and add some music or /Public/Videos/ on your storage device and put some videos in there.  This way when you look for it and you have a successful connection you’ll find the media. Also, this may be to initializing iTunes on your server.

I noticed I had issues accessing the media folders, until I actually put something in them, which is when I was able to read the media.


#4

I receive the same error message when clicking on the drive under Shared in iTunes. However, I can access and play the music from the drive through music. I tried the update database suggestion. No difference. Here is my firmware version:

01.01.16 with MioNet 2.4.0.62


#5

Hey there, all you fellow sufferers of the iTunes Shared Drive …

Sorry to say that I have nothing to add to say that the problem has gone away or has been fixed by the previous suggestions.  I’m using a MacBook Pro, which can access the relevant folders via Finder, and via the web interface, so it strikes me as more than a little odd that iTunes cannot share the drive.

However, I am also using the WD Anywhere Backup client, and that has been displaying ‘disconnected’ in the Backup window, even though the background services appear to working (I have reported this to memeo who are investigating it). This leads me to believe that there may (on the Mac at least) be some subtle problem in the protocol handling (or even some stupidity in the handshaking) of the software or firmware (at either end!).

The iTunes issue did not arise initially - it simply refused to show anything on the shared drive via that application and then, for some unknown reason, it decided to throw up the error (-3260) with port 3689 identified as the root cause of the problem.  Of course, as mentioned by the WD representative above, this error is all over the internet and it would appear to have been a problem for quite a while (one posting was in 2004!!).

Right, that’s enough from me for the time being.  My thanks to the other contributors to this thread for their helpful hints.  If I get to the bottom of this problem, I will share it with you all (and the World!).  My details are below:

MacBook Pro, with 2.4 GHz Intel Core 23 Duo, with 4GB RAM and running Mac OS X 10.5.8 (Leopard)

WD My Book World Edition I Details : 01.01.16 with MioNet 2.4.0.62 


#6

Hi, i write from Italy, escusemi for language…

On MyBookWorldEdition model  WDH1NC10000 there is this firmware 01.01.16 and ther’is not possible find a new version, 01.01.18

I have the -3260 error, and i find a solution

Thanks for your help

Fabrizio


#7

The My Book World has 2 firmwares now.  The latest for upgrading is 01.01.16.  There does seem to be people reporting a version 01.01.18 on the new releases, I think its some internal change.  Any ways.

I had the same error when using my iTunes server and the Error 3260.  Try this it worked for me

1.  Access the MBW unit network storage manage and click on the advanced tab. 

2.  Click on Media then click on iTunes.  Take the check mark out of the service so that the service will stop

3.   Click on Media again and choose Media Server, then Twonky media settings

4.    Click on Maintenance and choose rebuild data base.  (the server will restart and start rebuilding the data base)

5.  Go back to the iTunes server (I had to use the back button several times or you can log back into the user interface)

6.  Place the check mark back into the iTunes server to start the service again and set the scan to no less then 30 min.

Note: make sure you are using the latest version of iTunes and to allow enough time for the music to be rescanned into the indexing (may take a while depending upon how much music you have)


#8

i’m having issues too with itunes.

-3260 error suggesting to open port 3689

i have a mybook world (modelnumber wd100000h1nc-00) with the firmware updated when i bought it 2 days ago. it’s now 01.01.16 with MioNet 4.1.0.0.171

it’s connected to a belkin 54g router and my imac is connected to the same router (also with a cable)

the public folder is accessible through Finder and in the Twonky configuration i can see all the songs and play them.

i’ve only put 600 songs in to test. tried the suggested solutions above but none of them work for me.

(time machine backups work very well.)

anything else i need to add? a log?

thanks!


#9

if you tried the above and it is still not working, have you tried a reset on the MBW drive?  Press and hold the reset button on the back (youll need a paper clip or something) for 15 or 20 seconds.  the lights on the front of the drive will start fading in and out and then the unit will reboot.  this will reset the Admin user and login to default but should not delete any data or users or folders created.


#10

that worked :slight_smile:

instantaneously!

thanks a lot.

UPDATE:

it stopped working after 15 minutes… same error. i’m going to reset again.


#11

Did it start working correctly? 


#12

it did 1 time… 

reseted again with no luck…


#13

it has been working for over an hour now…

fingers crossed!


#14

I am having the exact same issue.  If I reboot the WD it works for about 15minutes and then stops. This is very frustrating.


#15

Is your issue that you cannot get iTunes server to properly work, or are you receiving the network error?

Did you make sure that your firmware on the unit is fully updated and did you try all the troubleshooting steps provided previously by James_k and myself to try and resolve this?


#16

Hi,

I resolved the problem just activating the AFP protocol (Apple Filinf Protocol) on the Music Share folder.

You should enter the WD server, choose Advanced Mode -> Storage -> Folder Shares and activate the AFP to your identity. After I having done this, iTunes properly connected to the shared folder and I was able to play the music stored in the WD drive.

Good Look!

Francesco


#17

I am receiving a network issue. If I reboot the WD it works fine for about 15 or so minutes. I have all the latest and greatest firmware.   I am going to try Framacchee suggestion when I get home today.


#18

I tried activating the AFP but I am still getting the same network issue.  Its just weird to me that if I reboot the WD, it will work for like 15 minutes and stop.  I have Windows 7 does that make any difference with configuring the WD to work.  This is extremely frustrating to say the least!


#19

Based upon the information provided, there may be an issue with the media server on your unit.  At this point if it is still unresolved you can either,

A. Try a factory reset of the unit.  This will delete all data, but will reinstall the Media Server.

B. RMA the unit.

In either case the data will have to be removed from the unit.  If you are in the US/Canada or the EU if you do an ADV. RMA you can receive the replacement unit first to transfer your data.  If you have had the unit less then 30 days I would recommend taking it back to the place of purchase for a refund or exchange.


#20

Try this, it should help with the Itunes server

http://:3689 the login is mt-daapd/mt-daapd and click on start full scan