Can't access Internet

My new WD My Cloud arrived today and so far it’s done more harm than good. I connected it to my router and ran the drivers from the WD website. That all seemed to work fine; the device showed up on my network and I could log in via the web portal. I tried to copy a file over and about a minute later it failed. Not just failed–my computer lost its Internet connection. (Other devices on the local network, like my tablet and Roku, continued to work fine.) After poking and prodding I found that I can VERY briefly have my computer communicate with the book; I successfully copied over a small folder of text files. But within a minute or two of trying to copy anything else my computer simultaneously loses the connection with the device and all Internet access. I’m still getting an IP address from the router but I can no longer ping the default gateway, which seems really weird to me. All I knew to try was to set a static IP on the My Book; no change. Do I have a defective drive here?

litlfrog wrote:

Do I have a defective drive here?

I doubt it… More likely a network configuration problem.

When you can ping the default gateway, can you still browse your Router’s setup webpages?

I can NOT ping the default gateway, nor can I get to any of the router pages, through the browser or through the NETGEAR Genie.

Sorry, I misread your description.

Are you using private IP space on your internal network, or public?

Private is:






IP addresses are in the 192.168 block. A couple of other things I noticed: 1. If I use the WD application to get into the drive and view it that way I can paste files there just fine. However, then the My Cloud does not show up on my local network and thus I cannot access it anywhere. If the device shows up on my network but I don’t do anything with it, it’s fine. But the minute I try to access it through File Explorer it fails and takes my PC down with it.

Seems to be an issue with your router (to drop pc’s connection) or your pc, bad nic drivers maybe? Have you restarted the router recently? Do you have another pc to test transfers within these devices? To isolate the issue, connect mycloud directly to your pc, enable internet sharing so the pc will assign ip to mycloud and test transfers or browse the share…

I’ve restarted the router several times. NIC drivers seem fine, never give me trouble otherwise. I can’t really believe that it’s anything more than a configuration problem somewhere–the router is almost new and my connection never drops out otherwise. Unfortunately I don’t have another PC to test with on the network. Can I in fact hook the the My Cloud directly to my PC with a USB cable? I tried that over the weekend and the PC never recognized that anything was plugged in. 

Not USB cable, the MyCloud USB connection is a host-only port. Use a good lan cable (>=cat5e), then enable internet sharing on your pc so it will assign ip to MyCloud (find your nic at the network connections, right click propertise, sharing, check allow)…

BTW I’m not sure about your router model or pc/network setups. Your tablets via wifi and roku media server is not that much bandwidth demanding appliance. So chances is that you didn’t encountered this earlier with only 1 gigabit PC attached to your router.

See this:

If that were the case though I’d expect the connection to drop out when I use the My Cloud app. It doesn’t. I successfully copied about 6 gigs to the device when using the My Cloud desktop app, but when I get in that way the device doesn’t show up in the Network section of Computer. 

Sorry I have never used any of the wd apps, think the app is using webdav fs protocol unlike smb2 in explorer. I’ve transfered 1TB of data at one go via explorer with no issues.

So . . . does anyone have something useful to try here? I created a support case with WD days ago and still haven’t heard anything.

So . . . Have you tried the suggestions on this thread and post back the results? And you don’t have another pc to test? Borrow a laptop?

If I interpret what you said correctly, it sounded odd, but I tried it. The only way to hook the My Cloud directly to my computer is to run the Ethernet cable from the port in the WD device directly to my NIC. Since I only have one Ethernet port that means I had to disconnect my Internet connection to try this. I enabled Internet sharing on the NIC in case that made a difference then I tried this. Nothing in my system seemed to know that the My Cloud was hooked up at all, so I gave up. And no, I do not have another computer to try this with.

I’m going to have to return this for a refund unless I find something else to try; a network storage device that I can’t access without a proprietary app isn’t terribly useful.

Yes what I advised you to do is odd. It’s just a simple direct Lan connection test w/o internet access. If your PC knows WDMyCloud is connected when the 3 devices are linked (PC/Router/NAS) but your PC doesn’t know this when only 2 devices are linked (PC/NAS), then I would probably be determined to try another laptop/PC. Then another router, cables and most probably another branded NAS?

I doubt if you happen to have a cross cable to test direct connection as seems your NIC doesn’t support auto MDI/MDI-X, but just drop that idea. If you choose to quit troubleshooting and choose to refund, good luck with your next nas…

Don’t get me wrong I understand your frustration. I’m just a reqular user who’s happy with this affordable low-end nas. Only disappointed with the latest v4 firmware of 64k page memory size which will definitely make me skip WD for next nas upgrade… We need a working Linux (-: