Can't access files in MyCloud from WD app on iPad

Hello all. This has probably been posted so sorry. I have a MyCloud and MyBookLive on home network. Installed WD app on iPad to access shares. Everything ok until about last week. App sees both devices but says “MyCloud inaccessible”. I have gone into “shares” on dashboard on PC desktop and “public access” switch is ON but is greyed out. I can’t change it. . Smartware and TimeMachineBackup shares show public access as ON and is not greyed out. Is this stopping me seeing my files from my iPad. Also when I go to Users (I am the only one), share access for Public, Smartware and TimeMachineBackup are all greyed out. Is this also the problem. Thanks if anyone can help.


It is possible your WD My Cloud needs to be rebooted in order to re-establish and re-assign proper remote access and user share permissions. The Utilities section under Settings in the Dashboard configuration page allows you to test your WD My Cloud device and get diagnostic information, restore the device to factory defaults, reboot or shut down the device.

it’s tricky to reboot if you are not on your home network and can’t get access. Very disappointed that 1. cloud access worked at home, and not when away, and 2. that support don’t bother to respond to ticket

Thanks for replying. I tried reboot and system re-store but no joy. In its new state it showed no cloud devices so I added my iPad manually, getting an activation code. The app recognised MyCloud with this code and now I can access my files. It still saw my old device on the newtork, so 2 MyClouds and 1 MyBookLive were displayed. I deleted the old MyCloud. Maybe after the system restore I should have downloaded the app again and it would have recognised MyCloud without a manual activation code. This is all wonky. I have found this with all my WD devices, they work but are just awkward. Thanks again.