Can't access expansion drive connected with USB to MyCloud

Hi! So I just got a new WD MyCloud and set it up. Now, I had a Seagate Expansion Drive which I connected with the WD MyCloud via USB and gave the necessary permissions to my user. Although I am able to access the Seagate drive via the WD cloud apps of Android, iOS as well as able to access from my Samsung SmartTV, I am totally unable to access the Seagate drive from the Finder of my Mac (ofcourse I logged in my User :smiley:). It does not even show up! I would be extremely thankful for any of your help.

P.S. I am using OS X Mavericks 10.9.1 and the WD MyCloud runs the latest firmware.

Hi, have you tried using the external drive name to find it on the network?

Yes I did, however no luck 

It does not work.!!! As long as that you have it as public you can access, whether you have it with permissions for users, it does not show up in finder.

It doesn’t even work as Public for me. I’m gonna return it back on Monday, unless ofcourse a fix is issued.

So IIRC (because I’m not a MAC user) Finder will, by default, only find shares that are accessible via AFP (Apple Filing Protocol.)

Have you tried accessing the USB disk via Samba instead?

Nope haven’t tried Samba, I’ll check & get back to you

Solved:

Use this in the Terminal —

echo "[default]" >> ~/Library/Preferences/nsmb.conf;echo "smb_neg=smb1_only" >> ~/Library/Preferences/nsmb.conf

 This will change SMB2 back to SMB. Some issue with Mavericks I guess. People please feel free to correct me if I’m wrong. It works for me, but lets help others.

I am sorry to say this does not work for me…:mansad:

Thank you anyway.

PD.- What I have found is instead of use smb://NameServe r is to use cifs:// NameServer  in my case cifs://WDMyCloud and then it works. 

changing from SMB:// to CIFS:// works for me too. thanks.

however i believe WD must address this issue, unless ofcourse if they believe “how many people would be using MyCloud with Mavericks with a USB storage HDD together anyway!

Well… I don’t think that they care at all, I sent them a email explaining all of this step by step and this is what I got a few days later…  

" Thank you for contacting Western Digital Customer Service and Support.

The Public folder is in reality the whole network drive. All the space of the drive is contained in the Public folder, so if you block or close the access to the Public folder in reality you are blocking the access to the whole network drive.

If you have any other questions or concerns please respond to this email and we will be happy to assist you.

Sincerely,
[Deleted]
Western Digital Service and Support Europe"

[Deleted] IS THIS?.. It shows how much they care about it… They didn’t even read the email…!!!

It is like someone ask me "What is the weather like?" and I say "I am good mate, thank you"

Im on 10.9 and it works fine for me. No issues, finder sees the drive and usb (Seagate Expansion USB3).  Connect as Guest :wink:

Yeap when is public only… “no problem” but with permission to any user or via ftp, then you will not be able to access 

Anyway this post is over for me… I got a warning from moderator… so… Have a nice day to all of you.

Well when we are to use it as a ‘Guest’ then it defeats the very purpose in the first place right?

Hehe dude you got warning for using some banned words :smiley: