Can't access drive on network

I have a My Book World Edition II.

It becomes inaccessible after a period of time. Sometimes a few days, sometimes a few hours.

I can still ping the IP address, but cannot see or logon to the web interface or see it from my Mac.

The only way to fix it is to power it off and back on again.

I’ve spoken to WD Tech Support and even had the drive replaced under RMA. Same problem occurs on the new drive.

  • Am using an IINET BOB Router/Switch
  • Many devices on the network, do not have any similar problems with any other devices
  • Latest firmware on the WDC My Book

Would appreciate any help.



Are you connecting the drive wire or wireless?

I have the same problem MBWE disappears after some time.

My backup fails. In the log  I find:

 read_data: read failure for 4 bytes to client (ip adress) Error = Connection reset by peer

I only use it for backup so frequently failing is very annoying

Some one with a suggestion?

Thx Hans

Wired. (I don’t think the drive can connect via wireless)

I’ve still got this problem.

The WD Backup software also doesn’t work under Lion OS (Which I’ve posted about in a separate topic.)

There has since been a firmware update, which I have installed - No difference, same problem.

This drive has been a complete waste of time and money so far.

Does anyone from WD actually read these forums and contribute something useful?

Similar problem here.  All firmware is updated… Able to access and backup to drive, but after a couple of hours use, the shares drop from the network.  Able to access via web gui management, but have to unplug power and plug it back in to get shares back online.

The same with me.

MyBookWorld 1TB white light, Windows7, dlink router

Evertthing works fine: access, shares, mionet.

And after some time drive becomes not responsive.

Ping works and light in on which means ready - but no gui, no share, no response.

The only way is turn-off

Any help?

Hi, for those not using a Mac, you may try disabling AFP protocol support under Network > Services in advanced configuration.

Maybe this helps, also disabling other functions not being used could help, as mionet or iTunes server…

Please tell us if you have any improvement. :wink:


I’m not using a mac, but I disabled the AFP protocol anyway, hoping this will solve the problem.

Yes, I’m having the same problem. Usually the network drive becomes unavailable when copieen large files (1 or 2 GB or so). The drive is still pingable, but the shares are not available as well as the http at port 80.

The log doens’t show anything usefull.

Can you report anything new on this subject? Seems to be a common (chronic) issue.


i have the same issue, i opened a case in WD and they answered as they were hearing about this problem for the first time. My drive is useless after the last firmware and they dont admit it.

Problem is that i have all my files in there that i can not even copy to move them to another drive since i often lose the connectivity. All i want is to throw out this drive asap.,

I have assigned my drive (My World Book 2 TB White) a permanent IP address. I use Mac OS X 10.6.8 at this time, with other computers/users with Mac OS X 10.4.11, 10.3.9 and Windows XP Pro, all with some issues, but never losing connections. Windows 7 Ultimate 64 bit, I have the same issues you all have described - sometimes I can connect, and when I do I lose the connection after a few minutes. I have many problems related to Windows 7- but no other OSs. I believe it is a Windows 7 Problem. I can’t prove it though I’m not an expert in Windows - it could be something I’ve done wrong, but I can’t afford Microsoft “tech” support. 

Hello, i have the same issue on My Book World Edition (White Light).

After a period of time, the drive isn’t reachable from the network. The NAS is connected to a D-Link Gigabit Switch.

I’ve installed the last firmware 01.02.12 but the issue remains. AFP is disabled, and now i’ve disabled the iTunes server too. In the next days i see if the issue remains.

This summer the drive wasn’t reachable often (every 1-2 days). As the temperature decreases (autumn-winter), the issue is less frequent. Maybe the cooling system of the MBWE is not good.

Anyone of this forum has fixed this annoyng issue with a fan or with a particular setting?

Thanks and sorry for my English.


Being in the same boat, the issue seems to be that you have bad sectors.  I think you’re drive might be toast.

Did you ever find a solution to the problem?

I have a similar problemasIjustinstalled aWD Live hub with 1TB hard drive.I have direct tv2pc installed.I get the media ok fromthe receiver to the pc,but when I try with the hubit showsthe playlist from the receiver but when I clickon it it says browser error.I amvery new at this .It does workwith my pc great.Thanks for your help.

Hi from Italy.

Same problem, cannot access at my WD MBWE (white light) from any of my pc, with any of my OS (Ubuntu, WinXP, MacOS Leopard).

Better, I can see it under the file managers, I can access via SSH (native under Linux and Putty under XP) but i cannot excange data to and from it.

And the webGui is deadly slow, when it works…

What can I do? Since I have not hacked it I have no editor inside to manage and modify the files, as per this solution:

Any alternative solution, maybe from the support team? =_=



Same problem here. I was transferring a 4 GB file from PC to WD MBWE II, i got message, cannot access the drive. I tried to ping it, works fine, TTL=1, but cannot access drive from PC. I tried to power it off using the power button, no response. I tried to hot the reset button too, no response. I finally pulled the power wire and plugged it in after few minutes. It starts responding. But, like some one said earlier. the GUI is very very slow.

I also see this -  2012/01/23 19:09:29  read_data: read failure for 4 bytes to client Error = Connection reset by peer ( is my PC IP.) - static IP for the nas

Hi from Italy.

I have installed the firmware 01.02.06 and 01.02.05 (downgraded from the 01.02.12), but the issue remains.

I have tried disabling all the services (iTunes, FTP, AFP) but the drive, after a certain period of time, is unreachable.

I can’t reach the Web Configuration page and the Shared Folders, i can ping the device only, configured with a static IP address.

I’ve changed two configuration files, removing the “nice” command, but the issue remains.

At the last i’d like to disable the Twonky Server, but into the Web Configuration Page, i can’t find the relative option.

Anyone on this board, has fixed this issue?



Hi, I am unable to help here but I have My Book World Edition(blue rings) 2 off), both connected via ethernet to the Router. One of them drops off the Network and I cannot access files - sometimes within minutes. The data is always there but the drive is inaccessible. I have not tried accesing  it by ip address, only as a Network drive but will try a telnet or ping. .When it drops off the Network the blue rings stay solid and it does not power off via the power button - the power cable has to be unplugged to bring the unit down. This drive called ONE1TBHOME is my Primary device and the other is TWO1TBHOME is by backup drive - which is now out sync and I have left it down until ONE1TBHOME can be fixed to stay on the Newtork.

Your problems seem very close to mine and I would like to stay abreast of what is happening and would happily try things suggested and contribute if I can.



I have noticed other threads that say I can restore the Disk settings for My Book World Edition(blue rings) admin password, IP address etc. to default without losing data - however if I did a Full Factory Default I would lose everything - something I really don’t want to do.

Can anyone advise on how I can do Defaults reset without losing the data ? Something about holding the RESET button down for a period of time. I have never carried out any software updates and the twin of my non accessible My Book World Edition(blue rings) functions fine but since it was the backup disk for my failing unit it is kept powered down.

I am also going to see if using a small fan blowing on the My Book World Edition(blue rings) that drops off the Network (not visible as a disk) improves the situation as other threads have suggested cooling problems. Oh God what a disaster. Let us all hope we can find some sort of solution.

Thanks everyone on this forum for all the suggestions. I will stayed tuned.


Hi from Italy.

I tried to update Twonky Server, but the issue remains. I’ve reduced the log to the last 100 events, but the drive is always unreachable. I’ve installed the 01.02.05 firmware.

I have to restore the default settings? But i lose all my data if i do this?