Can't access dashboard (Win 10)

When I logged into the dashboard a few weeks ago it worked perfectly. Today I need to create a new share and when I click on WDMyCloud in Storage, instead of Firefox opening with the login screen it opens and says
“Forbidden
You don’t have permission to access / on this server.”

I know it is probably something simple but I can’t see what I am doing wrong. Can anyone help me?

I forgot to mention that I can access the existing shares normally by clicking Win+E>Network>WDMyCloud

It may help if you provide a screen capture of what actually comes up. You can use the snipping tool to capture it, just be sure you remember where you save the image and what name you gave it. Upload the image with your reply.

I’m not sure how it will help but OK

Unfortunate.

This is returned by the http server when it either cannot read the filesystem that hosts that web content, (filesystem permissions being the major culprit), or when configured to require an authenticated user. (such as via an .htaccess file)

There is a third potential option, which is that by default, Apache2 throws this error when it is directed at a folder that does not have an index.htm(l) inside it. (it does not give directory listings by default,) This would indicate an incorrectly configured web root directory entry in the httpd.conf.

Can you ssh into the NAS? The first thing to try here is to reboot the nas. If it persists, we need to rule out something clobbering the web root’s file system permissions as the culprit, and for that we need console access.

You can type, 403 Forbidden, in the search area next to Start and look at what comes up. Here is the link to one result I found. https://www.lifewire.com/403-forbidden-error-explained-2617989

MyCloud uses Apache2 as the httpd. I listed the specific reasons why apache throws this error. If this is a gen1 mycloud, something may have clobbered the webroot’s filesystem permissions, which will force apache to return this error, because it cannot access the files, and thus cannot present them to the user on request. (I have dealt with this several times setting up apache hosts.) It is at least helpful, and returns 403 (access denied), instead of 404 (file not found).

If this is a gen2 mycloud, the webroot is hosted on a read only cramfs container, which is mounted onto a ramdisk hosted root filesystem. A reboot will completely refresh the filesystem from these read only sources, and it should work like a charm.

To get an error like this, suggests that this is a gen1 mycloud.

The first thing to try here is to reboot the nas.

I feel so dumb for not thinking of trying that. Whenever someone mentions a computer related problem the first thing I always say is “Have you tried turning it off and back on again?”

It seems to be working now.

1 Like

I know I am posting to an old thread, but wanted to post another reason this can happen that wasn’t mentioned.

If the NAS thinks a client is accessing the dashboard from a network that’s different than the network the NAS is on, it will throw that error because Apache is configured to disallow off-net connections by default.

On the various My Cloud models that allow you to enable remote dashboard connectivity, that, of course, is a different story.

Hi All,

As per other posters to this thread, I’m receiving the 403 and 404 messages when attempting to log into my WDMycloud device. However, in my case, this is an intermittent problem. A reboot sometimes clears the problem and allows me to log into the device, but in these cases, the problem then re-occurs the next time I try to log in. A reboot doesn’t always clear the problem. I also found that re-starting my router allowed me to log in on the next attempt, but this may have been a co-incidence. I suspect a failing unit, but am also concerned that it might be a symptom of someone accessing my device and attempting to block my login. This may be paranoia on my part. I’m confused by the different but similar models for these devices, but I purchased mine several years ago, it’s a 4TB single drive WDMycloud unit with firmware beginning with 04.xxx. Any suggestions or clarifications would be very gratefully received, including a sensible upgrade path for a similar sized replacement if the symptoms described indicate that this would be the sensible strategy.
Regards and thanks,
Tim Pennick

This error indicates that the server has determined that you are not allowed access to the thing you’ve requested, either on purpose or due to a misconfiguration . It’s probably because the site owner has limited access to it and you don’t have permission to view it. The vast majority of the time, there’s not much you can do to fix things on your (*client) end. There are three common causes for 403 Forbidden error (server side) . Here they are listed from most likely to least likely:

  • An empty website directory
  • No index page
  • Permission / Ownership error