Can't access dashboard either, tried everything

Suddenly I can’t login to my MyCloud EX2 Dashboard as an administrator. I can access my shares and I can login as a user but without access to settings. The IP address of the EX2 has not changed from what it always is, according to my router.

The EX2 is running version 2.10.310 and RAID status is Good according to the WD desktop utility. The WD site says that the MyClouds recently were upgraded to version 3, but mine says it is still version 2.

I can’t login to it via SSH using the Putty application for Windows.

I have tried 3 different browsers on 2 different computers, Mac and PC. I have cleared caches and reset the EX2 with the reset button. I still can’t login to the Dashboard. This behavior contradicts the WD doc which says that resetting the EX2 will permit changing the login.

I have shut down the EX2 (from the WD Windows app) and restarted it but still can’t login to the Dashboard. I have power cycled the router and the EX2 but these make no difference.

I have removed all other computers and Ethernet devices from my network. My PC is connected to a router which is connected directly to the EX2. The router is connected to cable Internet service. I have tried different Ethernet cables with no result.

The WD desktop utility has a menu selection named “Settings”, but all it does is open a browser to login to the Dashboard. This will not accept my admin login.

I tried to use the WD Setup app to create a new admin user but the app modified my firewall and disabled my Ethernet which I was able to re-enable. The WD app offers to set up remote access, which I definitely do not want, but if I decline it will not create new users. Why can’t I create a new user without enabling remote access?

If I restart my PC, the EX2 usually reports that it is doing Volume Migration, for no reason that I can discern. I am not migrating any volumes. The EXT2 has 2 HDs in it and has had them for some time. The migration completes within a minute or two, but this does not enable login. The lights on the EX2 are all blue.

I tried to make a new support case online but the WD support form will not accept my accurate serial number or model number copied from the label on the EX2 or on the box. It keeps asking me for a valid SN or MN but I have carefully entered these. I tried numerous times from multiple browsers.

Please help.

Read the manual to do factory restore. Maybe that will help.

I am also getting lots of Power Supply failure messages and at least one Volume Corruption message. Could these be related to some known issue?

I don’t see how to do a factory restore without Dashboard access.

Hi WD40,

if you already tried to “soft reset” (5 seconds procedure) the EX2, you can can wipe out the actual config and perform a “System Restore” with 40 secs procedure (see below).
Then, you will have a brand new EX, but data on HDs will be still there (no data loss). So, you will reconfigure from scratch (user/psw/etc.) the EX2.

“The Reset button may also be used to perform a System Restore
on the device. At the same time as the power is plugged to the My Cloud
device, pressing the Reset button and holding it for about 40 seconds,
will make the device to go through a System Restore instead of a Reset.
This System Restore will not cause data loss”

I performed the 40-second System Restore. Afterwards, the EX2 is in exactly the same state that it was before. It does not allow admin login, whether with or without a password or user name.

swap it…

I was finally able to do System Restore by shutting down, unplugging from power, then holding Reset for 40 seconds while reconnecting power. This seems to be an alternate method that should be included in the documentation.

I was able to login to the Dashboard and create new admin users, do a Disk Test and configure all settings.

However, the EX2 is still malfunctioning. It frequently reports that it is shutting down, when it has not been commanded to do so. It frequently rebuilds volumes when Disk Test has already shown that the volumes are OK. It also randomly reports network loss when the network seems to be normal.

Isn’t this due to a faulty 2.10.310 firmware update? I implore WD to correct these problems - and to fix its website so that customers can enter support issues.