Can't access anything on EX2

Hi, I have a WD ex2 anda macmini server that is constantly connected to the EX2.

I went two weeks on vacation and when I arrived I noticed that I had a new update to the EX2 software and although I have disabled automatic updates my EX2 updated anyway. Now I can’t access EX2 either with smb nor afp.

SFTP and the Dashboard randomly work or not, and I can’t do much with it, it’s never responsive and keeps blocking.  By accessing with ssh I noticed the wdmcserver process is using 27% of the CPU and finally one of the disks started showing a red light blinking (or orange!). 

This is one of the worst purchases I ever did… I can’t acess the thing it’s always slow and always indexing (I have disabled iTunes server and Twonky) And I create weekly about 50 gb of images so it keeps indexing …

Is there anything I can do to sort out this kind of issue? I already tried the reset button on the back but it only changes the password. 

I just want a simple device I can access on my LAN … and this one is being a pain to work with… 

Thanks in advance 

3806     1 root     S    1789m359.2   0  0.2 /usr/local/wdmcserver/bin/wdmcserver -v /tmp/Volumes.xml

I managed to login with ssh, and I got that line from TOP. Can anyone please tell me if that 1789m could be the problem? I tried to kill the process (kill 3806) but in this firmware it doesn’t work …

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country