Canonical file set for new theme?

OK, I’ve done as much searching around here as I could to get up to speed on how to create new themes and upload them to SMP.  I have a few remaining questions though:

  1. What is the correct file structure for a theme to be validly parsed?  I downloaded the current SMP firmware and found the /src/libs/RES_RV/resource folder.  Its structure has five folders: font, image, mo, theme_builtin and xml.  However in other threads, third party themes seem to have a flatter structure: xml files as a flat list (not in a folder), but other folders the same or similar to the built-in theme.  And then some of the theme files are symbolic links, e.g. image/accuweather -> /opt/osd/image/accuweather. Is /opt/osd/image a fixed SMP firmware location?

2. What is the canonical file set for a new theme? (the minimal file set which will be validly parsed)? For example, I only want to modify a few of the Mochi theme elements to begin with (get rid of that annoyong spinning loading arrow, for example, by replacing the relevant png’s with empty transparent png’s).  Do I have to include all the other png’s and xml’s even if they are the same as the defaul theme? (SMP simply fetches the default XML if an uploaded theme doesn’t have it) or does the whole theme folder and file structure need to be replicated to work?

  1. Is it possible to change a theme to get rid of the alert that briefly pops up in the top LH corner of the screen, upon starting a video, that indicates audio format and subtitle setting (e.g. “Audio: PCM Subtitles: Off”)?

Thanks for any help.

Just modify the things you need … the Live Streaming will use default xml/images for the rest of the theme

One “rule” the SMP has … you must include a meta.xml in a theme upload.

For no loading icon and no audio / no subtitle notification i posted a mod for that a while ago …

http://community.wd.com/t5/WD-TV-Live-Streaming/Not-able-to-get-rid-of-the-re-load-icon-even-with-auto-play/m-p/628411#M24958

http://www.mediafire.com/download/4mboo9ysgq1mcv0/noloadingicon.zip

1 Like

That’s great, thanks (I haven’t uploaded it yet, but I don’t doubt that it works given the other posts).  Out of curiosity, which bit of the XML turns the Audio/Subtitle notification off?

beejay wrote:

That’s great, thanks (I haven’t uploaded it yet, but I don’t doubt that it works given the other posts).  Out of curiosity, which bit of the XML turns the Audio/Subtitle notification off?

the following code was removed to disable the Audio/Subtitle notification.

<wrapper disable="@@disable_subtitle_audio_info">
<image image=“image/video_playback_subtitle_info_bg.png” x=“70” y=“36” w=“310” h=“83”/>
<text text="@@subtitle_info" x=“87” y=“53” w=“276” h=“22” fontsize=“20” textcolor=“0xffffff” align=“left” speed=“1” delay=“2”/>
<text text="@@audio_info" x=“87” y=“83” w=“276” h=“22” fontsize=“20” textcolor=“0xffffff” align=“left” speed=“1” delay=“2”/>
</wrapper>

1 Like

I have downloaded the noloadingicon zip, but when I tried to upload the xml file to the appearence with Mac and Safari. I keep getting “Invalid file, Please correct file.” How can I tackle it? Thanks.

you upload the entire ZIP file … (not the XML file)

I just tried to upload the whole zip file, It still shows the Errors Invalid file, please correct file. 
I just bought the WD TV live streaming media player, is the problem relate to the latest version firmware?

Thanks

Question:. When you download the the ZIP … is your MAC with Safari automatically *Unzipping* the contents and you are *Re-zipping* them ?

If so … read here

http://community.wd.com/t5/WD-TV-Live-Streaming/How-can-i-install-a-new-themes-to-my-wdtv-live-streaming/td-p/532235

Disable “auto unzip” in Safari

http://community.wd.com/t5/WD-TV-Live-Streaming/Edit-Mochi-Theme-to-remove-loading-arrow-and-subtitle-audio/td-p/679959

Second Question: Have you tried a different Web-Browser ?

Thanks! I used Chrome and it works!

kongchunhei wrote:

Thanks! I used Chrome and it works!

nice to hear :smiley: