Cannot Use the send Link feature

Ok so since getting this thing it’s constant problems. Everything has been working fine though for the last few months but now when I glick the copy link feature and send it to someone they get

“This webpage is not available”

If I use the cloud desktop app It works fine. It’s just the links.

Any help would be great. Thanks! 



I recommend you try this:

1- Turn off remote access.

2- reboot the My Cloud drive.

3- Turn on remote access.

4- try again.

I have had same problem… never has worked… previous firmware and current.

I tried suggested fix and it still says website is not available.

I’d really like to find solution if there is one.

For me, the feature never worked as it should either. However, if I changed the port from the URL to 80, it suddenly worked… 

This is far from practical as you need to change the url manually every time. But it does the job in the rare cases I need to use it.

In my opinion FTP is the most reliable way to share files over the internet with the my cloud.

I also can’t make FTP work from outside my LAN. How do you do that?

That’s most likely a router issue. You should forward port 21 to your my cloud. But there can be numerous implications and I’m not really an expert in this