Cannot update to new firmware


#1

Hi all,

I have My Passport Studio 500Gb - with 2 partitions on it.

I try to update firmware using the utility from web (Update the Drive Firmware  (last updated 11/18/10))

but the utility writes: no drive found - disconnect all other USB devices and connect only the disk.

Rescan.

I unplugged everything I could and rescanned, but it wont help. But I see and can access the disk normally.

Please, how can I update the firmware?

regards

tomas zeman


#2

Low level communication in between your drive and Firmware update utility is not working. try installing SES driver from here.

SES Driver Download:

http://download.wdc.com/smartware/WD_SES_Device_Driver.zip

Go to Device Manager and look for WD Drive Management Devices >  WD SES Device. If not listed, you need to install above driver manually. Look for “Other Devices” in Device manager while your My Passport is connected. Also now you can use Windows 7 Update to download required driver. Be sure to disable antivirus software while FW update take place. It might block your update utility and show you an error.

To invake Device Manager, type on RUN; devmgmt.msc


#3

Hi,

I have tried it but it did not helped. I have tried it on Windows XP notebook and on Windows 7 Notebook (also restarted them).

WDC SES drive is there ok, but the update process cannot detect the disk :frowning:

please would you have any other help?

Regards

tomas zeman


#4

Hmm… it is little late in here… 4.54am. must get some sleep:  :cry: 

You have a Passport with USB and Firewire interface. I should have ask this question in the first place. Why you need a FW update at this time? Do you have any issue on drive performence?

For the time being read this Post. It may or may not have somthing to do with your issue. But it is always better to be informed.

http://community.wdc.com/t5/My-Passport-for-PC/How-to-eliminate-potential-problems-on-USB-Powered-Drives-and/td-p/118262

http://community.wdc.com/t5/My-Passport-for-PC/FIX-For-Drive-disappearance-issue-on-Vista-amp-Win7-XP-Scenario/td-p/125674