Cannot unlock WD-locked drive!?!?! Any ideas?

I have a 3GB WD My Book Essential (USB 3.0 version) drive that I’m using with my Mac (OS X Ver. 10.9.5).  It’s “locked” (encryped) using the WD software and I’m not able to unlock it.

When I plug it in, the drive is not visible in Finder but I can hear it spin up and “WD Unlocker” mounts on Finder. When I go to that, there is the “” program. When I click on that, a box pops up with this message:

“This drive is not unlocked”…

Name: [This is blank here]

Serial: [This is also left blank]

Size: 0 kb."

Also, I can hear that the drive is active: It’s clicking away like it’s reading/writing. This goes on for a while (15 min or so?) until it finally spins down.

But in the past, the program that is in the volume that automatically mounts has not always worked, but a “WD Drive” that I’d downloaded did. Now when I click on that, I get an error message, “WD Drive Unlock quit unexpectedly.” This happens everytime I try to open it.

I’ve tried restarting the computer, etc. – unplugging and replugging the drive back in – and that doesn’t solve anything.

Any ideas as to how I can access the drive?

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country