Cannot uninstall smartware update

When I tried to update smartware to the latest version 1.5.1 a couple of things went wrong. My Wacom tablet stopped functioning as soon as windows found a driver for the MBL, smartware appeared double in my system’s settings (both old and new version) and nothing worked like it should anymore. So I tried to uninstall everything and re-install the former version which seemed to work fine. However, the 1.5.1 update won’t uninstall anymore. This is the message I always get:

“there is a problem with this Windows Installer package. A program run as part of setup did not finish as expected.”

By now I’ve tried to clean the registry, remove the directory folders by hand from the Program Files directory, used different uninstallers and so on, nothing works. I somehow managed to get the version running fine again, but still the 1.5.1 version is there and in hardware management I can see that Windows can’t find a suitable driver to install (the website of the device tells me “the Network Link is down”), even though the MBL functions properly. Anybody any ideas what could be the problem?

B.t.w. I’m on Win 7 - 64.

I think you should call WD on this one…

I did ask WD support and they adviced me to use microsoft’s Fix-it service ( to remove the software. That was a good tip, it worked fine.

Afterwards I re-installed everything using the latest updates directly but I still can’t get it working properly. Smartware won’t open and the dashboard entrance doesn’t show up in the quick view. So, still strugglng. I’m going to clean the registry once more and try re-installing it once again.

what firmware is your MBL on?

Also, I think you need .net 3.5. sp1

I allready updated the MBL with the latest firmware, no problem so far. On my pc the latest version of .NET Framework 4 Client Profile is running. I don’t suppose I have to downgrade that, or  should I?

Well, fingers crossed, but I might have figured it out. The problem was (partly, well… ok, for a big part) created by myself for guiding the MBL to a driver when Windows kept telling me it couldn’t find one. I allready uninstalled that driver again, but somehow windows now found other drivers and automatically asigned it to the MBL (causing my Wacom tablet to die on me). Now that I removed these drivers and re-installed everything once again (from a cd created from the iso-file from the download section) it all seems to work fine. Smartware is up again and recognises the MBL, dashboard is available and my tablet still functions like it should. Hope it stays that way. Thanks for the help.