Cannot Select Shares within WD Smartware (MyBooklive)

I’ve just upgraded to Window 8, since then I’ve been unable to perform any backups to Mybook live as I cannot make any selection in the home tab specific shares. All the shares are visible in the drop down list however it makes no difference which one is selected as it will only default back to the the first share in list

I also notice that My Book live is showing an error in Device manager:This device cannot start. (Code 10)

My windows 8 problems was fixed when i set WD quick view to run in XP mode (find the exe file - right click file - select properties)

Thanks for the advice, however I tried it but it didn’t work

I also went “Code 10” after upgrading to Win 8.  XP mode is hardly a fix. 

Of course, this problem (i.e., "Code 10) is perfectly understandable when one considers how unexpectedly Windows 8 was thrust upon the world.  Absolutely no warning from Microsoft that a brand new OS was coming!  I mean there just was no time for any developer to plug a device like the MyBookLive into a Win 8 computer, turn  it on, and just see if the old drivers and software worked much less write any new code, was there?   [Sardonic sarcasm]


i have been playing around with windows 8 previews (from developer preview to release preview) since september 2011, and i have a validated windows 8 since august 2012… is not M$ problem!

i have been writing to WD since then, but no answer so far… today i saw a brand new WD app in the windows 8 store, but it does not recognize either WD MyBookLive nor WD TVLive  (it says the product is not certified for windows)!

“Code 10” i guess means problem of driver… why WD takes so long? …and in the meantime they make apps for win8 store we cannot even use!!!

i hope, since the release of MyBook 3,0, WD does not forget about customers of WD MBL who upgraded to windows 8!

The App description does not include My Book Live as a compatible device.  That is unexceptable!  WD needs to fix that.

Not sure what you are talking about “Absolutely no warning from Microsoft that a brand new OS was coming!”.  Previews of the OS have been available for over a year.  I installed the developers preview back in February.  This is WD’s problem, not Microsoft’s.  WD need to fix the issues.

at the end he says [sardonic sarcasm] :wink:

anyways, it always takes two to tango… but definetely WD has to look into this issue (I believe they are already on it), and possibly release a win 8 app for MyBookLive

The problem seems to be the authentication.  Windows 8 Home Edition inserts the computer name as your domain name.  Since the domain/user name combination is not a valid user on the WD drive it fails to attach.  Public shares show up okay.  Changing a private share to a public share makes it show up.  Of course that defeats the purpose of private shares.  I tried adding a user including the forced domain name and the WD does not like it.  So they are not compatible.  Tomorrow I may see about turning on the Homegroup and figuring a way for the WD to join that.  M$ did screw up because the computer is not the domain name and the computer properties does not let you select a domain name or more more important tell it you do not want your computer name to be it.

I have exactly the same problem with my Win 8 machine and not being able to select a specific share.  It seems that WD have lots of connectivity issues with Windows of all genres.  I have W7 and Vista and each has it’s own peculiarity when both recognising and accessing the drive.  It’s very frustrating to say the very least.  I will just have to settle for backing everything up in in the SmartWare folder and give up on the idea of specific shares for now.  Hopefully they will come up with a patch soon but reading the other threads and topics here I am not holding my breath.