Cannot see MyCloudEX2 in Windows Explorer on new HP Pavilion under Win 10

#1

Hi,

Have had the NAS for about 3 years and it has never missed a beat. I have purchased an HP Pavilion 24-A270NA-i7700TB PC and cannot see the Drive from WE, either in ‘This PC’ or in the left hand pane directory structure. I also cannot open it from the WD App in the bottom right hand tray.

I have tried Mapping but to no avail. I can launch WE such that it sees the drive from 'Run App" using the IP address.

I have also modified the SMB protocol from SMB 2 to 1 & 3 respectively, but it does not offer a solution.

I’d appreciate any help with this.

Thank you

Hixpix

#2

First, see the dedicated subforum for the My Cloud EX2:

https://community.wd.com/c/network-attached-storage/wd-my-cloud-ex2

This subforum (My Cloud) is generally for the single bay/single drive My Cloud units.

Also see the following post that discusses various thing to check in Windows 10 that may be preventing My Cloud access. Specifically see Windows 10 Specific Method 1 through Windows 10 Specific Method 5 for suggestions to try.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

1 Like
#3

Hi Bennor,

Thanks for the quick reply. I will work through the suggestions you have forwarded.

Sorry for posting on the wrong sub forum. It’s my first post and found the forum a little confusing first time round.

Thank again for the help!

Regards,

Hixpix

1 Like
#4

Hi,

Worked through the list and at the Homegroup configuration everything came good.

Thank you again for the prompt help.

Regards

David