Cannot see MyCloud on the network after upgrading to Win 10

#1

Hi all,

The problem is that, after upgrading my machine to Windows 10, the drive (MyCloud 3TB) is no longer visible along with other computers on the network in Explorer athough I can map its shared folders as network drives. Also sometimes, after restart, those mapped drives won’t reconnect and I have to do it manually.

The problem occurs on my Samsung laptop but not on my desktop where the upgrade to Win10 went flawlessly.

Thanks!

#2

Hi there and welcome to the WD community.

I have Windows 10 on my computer and have not experienced this, have you tried to ping the device or accessing it through its IP address? 

#3

When I upgraded to Windows 10, my NAS drive were no longer visible on the network. In my case, this was due to the Norton Security Firewall, which also updated for Windows 10.

Solution: Open Norton Security. Click on Settings. Click on Firewall. Under General Settings -> Network Settings -> Network Trust -> Click on Configure. For your Network Connection, change the Trust Level to Full Trust. Click on Apply. Restart your PC.

Note: Counterintuitively, setting individual Device Trust levels does NOT work.

#4

While I am using Norton 360, this did not fix my problem on Windows 10. I can see the MyCloud device under “Network” in Windows Explorer. However, I cannot access it through Windows Explorer. I can access it by putting the ip address into a browser. What is interesting to me that immediately after the Windows 10 upgrade, I had full access to the MyCloud and mapped a drive to it. Then I tried to connect to a Homegroup,which failed, and have not been able to access it since. Any ideas would be much appreciated.

#5

This worked for me and all 3 of my Windows 10 computers (found it in a Windows 10 forum.)

Can’t see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!

Apparently the latest Win 10 update corrupted a version of MRXSMB and this disables the latest version and re-enables the prior version. Works great. Hope it helps some of you searching vainlessly.

Why WD experts can’t find this and make it known to everyone is beyond me, but … I have notified them via email and hopefully they will test it thoroughly and make it widely known

#6

FYI. The changing of the SMB setting within Windows 10 was posted, last December, in the 
Compilation of Windows 10 Methods, Steps and Solutions thread that is the first tacked thread at the top of the subforum. That thread also includes the command line commands to reverse the SMB change in Windows 10.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576