Cannot see my book world edition in finder. HHHEEELLLLLPPPPPPPPPPPP


i have recently brought a 1tb my world book edition network HD. i have followed the instructions but i cannot see the WD in my finder under shared, i can however see the wd in time machine. i am trying to partiion the drive half for time machine and half for drag and drop but i cannot do this because it cannot be found in disk utility. i am on a macbook pro MAC OS X 10.6.3 Snow leopard. any help would be great as this is driving me carzy !!! lol




I need the same type of help with my MBA, except My Book 4T World Edition shows up in Finder shared, but not in Time Machine.  I have transferred files to the shared files of My Book so my network connection is good.  I have tried every possible way to configure My Book in Time Machine with addresses and passwords, but nothing works.  Please advise if you can.

Ill try and answer both of these questions


you may not see the drive in finder.  please see the link below and let me know if you still are having issues.  Since Time machine sees the drive you have the latest firmware, this may just be a network discovery issue with your Mac.

You cannot partition the drive.  The TimeMachine partition is a virtual partition and will grow with the backup as necessary.  There is no way to limit the size of this virtual partition.


If Time Machine does not see the drive you may not have the latest version of firmware.  Please update or check your firmware version on the dirve and ensure you are at the latest version.

James_K I was experiencing the same problem as craig1989 and i fixed it following the given instructions (using connect to server).

However I still can’t see the drive in Time Machine… I’ve ensure that I have the latest firmware, but still doesn’t work. Also, iTunes doesn’t find the drive :(…

I’ve try to fix this issues many times following different posted opinions and nothing works…

I have Mac OS X 10.6.3 Snow Leopard.

Any suggestions?

Thank you.


I have a similar issue. If I use the Connect to Server tool, I can get access to dirve. However, when styring to install a back up plan, step one is to select a destination drive, or in my case, a Network Folder. When I try to point it to the WD drive, Finder shows it as an option, but when I click on it and after name/password, Finder just spins and never links up the sw with the drive. It just hangs. Suggestions?


Hey James – THANKS this link got me into my drive. Now I can copy the files I need from it and await the proper firmware update. Very grateful indeed for the advice on how to get into the drive. Cheers jjdoyle