Cannot see folders/shares from computer through the Web Interface

Model number: WDBCTL0040HWT-NESN   4 tb My Cloud

Windows XP sp3

I’ve had my MyCloud set up for about 2 months and, until a few days ago, everything was fine. But 2 days ago I opened the dashboard to add a new folder/share and, while in the dashboard I might have made some other small change which, unfortunately, I can’t remember now. After that dashboard session I could only see two shares – Public, which I have never used for anything, and the last folder I created. In actuality, there are 17 other folders. When I clicked that last created folder, I got what I can only assume was a Windows error message which said, "

\WDMyCloud\PhotosLizSwitzerland is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Access is denied." After this, I spent several hours Googling, reading this board and emailing WD support. (no response yet). Then yesterday, when I tried using the Web Interface again, I got the Windows security pop-up asking for user name & PW. I typed “Administrator” in the user window and my administrator PW in the PW window. Now I can see one single folder on the MC – Public (and the FAX/Printer) folder. I can see all shares/folders through my Android phone and tablet apps. I can see all folders through the “WD My Cloud” desktop app, and they all show up on the Dashboard. Other users can see all the folders they’re allowed to see. I have check everthing I can think of in Dashboard – Users, Shares, Settings, etc, since I believe it was through the Dashboard that the problem originated . .  or not.

Anyone have a clue as to what I can do to straighten this out?

Thanks in advance,


Have you tried a device reboot and resetting the admin password? It could be a credentials conflict.

1 Like

Yes, I’ve rebooted and have done the paper clip reset. The credentials/permissions error messages/popups all seem to come from Windows. When I call up the Web Interface, I immediately get the permissions popup from Windows,but it accepts “Administrator” in the user window and my Admin password. After that is dealt with, I see the WDMC – but only one folder/share – “Public” plus the FAX/Printer link. It does not display the other 17 folders/shares. I read somewhere while Googling that the problem may have something to do with the settings in the Public share versus settings in the other 17 folders, but I have yet to discover the differences.

I think I’m going to explore this from a Windows permissions/credentials angle than from the WDMC aspect. Thanks again for your response – it’s the only one I’ve gotten so far.

NEW TWIST in the mystery. Part of this problem is that, since a few days ago, I have only been able to see one share – Public – plus the FAX/Printers link, when I view the MC with Widows Explorer or when using Start-Run-\WDMyCloud, which I assume is also using Windows Explorer.  All shares (17) show in Dashboard and when I use the WD My Cloud desktop app.

Another twist – if I try to to turn Media Serving on or off for any share other than Public, I get the 400099 Error message. But when I click the OK button, and the box closes I see that the change was made anyway regardless of the Error msg. 

Today, in Dashboard, I created a new share and named it “Test”. I closed Dashboard and looked at the WDMC with Windows Explorer and – guess what – I now see two shares --“Public” and “Test”. Also, I can turn Media Serving on or off without getting the 400099 Error msg in these two shares. But, if I turn “Public Access” off for the “Test” share, I have to log in as Administrator to open it.  If I turn “Public Access” on, then I can open it with out having to do the administator thing.

Unfortunately, I’m still unable to connect the dots.

Have you tried other computer systems such as Microsoft Windows 7, Windows 8, or Windows 10?

no. Everything was fine on Win XP until a few days ago.