Cannot see files on my Ubuntu network share


#1

Hi, I have set up my server with Ubunut 10.04, set up Samba sharing.
I can see the files in the samba share from the windows PC’s connected to the server.
My little Western Digital HD TV media box however cannot see these files. I can connect to the server from WD but it keeps telling me “there is no media in the current folder”. Am I missing something?


#2

Solved - had to do a “pin-hole” reset and disable automatic login…works fine now.


#3

Just out of curiousity, did you change something in the SAMBA config that required this?


#4

I am going to try this because I have been experiencing this as well with my FreeNAS box. FreeNAS supports Samba and UPnP, but only one at a time and if both are activated Samba overrides UPnP. Of course if Samba is disabled, my PC can’t access anything on it and my mapped drives cannot connect.


#5

I have an LC Nas.  First, I have the same problem:  not see any movies files and directories.  I go in settings on the WD tv live and disable the automatic login.  Now it works fine.  I see all the media files.


#6

Usually, after you successfully log in, turning Auto Logon back on will work fine.  


#7

I’ve setup my WDTV Live with B-Rad’s firmware with Ubuntu Linux about 4 times. I format my computer and then have to spend a few hours pulling hair and teeth trying to get my WDTV Live to communicate with my server properly again. I wish I was smart enough to bookmark/remember what I did the other few times to get this thing to work properly.

So. Any ideas why I get this message “The media server could not be accessed” on my WDTV Live?

I have edited my smb.conf file to this:

#======================= Global Settings =======================

[global]
     usershare owner only = False
    workgroup = workgroup
;    netbios name = hoppus
    server string = %h server (Samba, Ubuntu)
    name resolve order = bcast host lmhosts wins
    map to guest = Bad User
    os level = 33
    preferred master = yes
    usershare allow guests = Yes
;    usershare max shares = 100
    usershare owner only = False
;    printing = cups
    printcap name = cups
;    printcap cache time = 750
    cups options = raw
;    load printers = yes
    use client driver = yes
    username map = /etc/samba/smbusers
    security = user
    encrypt passwords = no
;    guest ok = no
;    guest account = nobody

[printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    create mask = 0700
    browseable = No
    guest ok = Yes

[print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers
;    browseable = yes
;    read only = yes

[Movies]
    path = /media/Media/Movies
    writeable = yes
;    browseable = yes
    guest ok = yes

[Tv]
    path = /media/Media/Tv
    writeable = yes
;    browseable = yes
    guest ok = yes

[Music]
    path = /media/Media/Music
    writeable = yes
;    browseable = yes
    guest ok = yes

All help would be appreciated!

Thanks in advance

Aitaix


#8

I’m no Samba expert, but I DO know that lines that begin with “;” are comments and are ignored.

Are you sure those lines are not important?

Particularly the BROWSEABLE lines?  I would think that would be needed?


#9

Thanks for the reply.

I removed the ; from those lines and still get the error “the media server could not be accessed”

I wish I remembered how I set this up…:manmad:


#10

Probably a dumb question, but, did you remember to re-start the samba daemon after changing the config?


#11

ya no luck…