Cannot restore Time Machine backup

I bought a MyBookLiveDuo some months ago and since then I have been backing up my Mac on it via Time Machine.
I had to replace the HD on my iMac so I did a latest backup, erased my mac and gave it for repair. Returned back, I discovered my backup does not work.
Has been two weeks I’m trying to do a restore, no way to access my backup.
Tried to uograde my WD device to latest firmware… Nothing.
Inside MacOS I got two units: MyBookLiveDuo and MyBookLiveDuo-backup. I can’t access the second one. Trying with migration assistant results in a ‘connecting’ going on forever.
Trying a full restore from system boot results in a ‘cannot find any time machine backup’ message, after successfully connecting to my backup partition.
Wanted to copy the backup to an usb drive but I can’t find the Backups.backupdb folder.
What to do? I got a Backup folder on the MyBookLiveDuo but it doesn’t seem the full backup folder to me.

Check the link below, this might help

I’m sorry but I already know how Time Machine works and how to do a restore. The problem is it doesn’t work.

A complete restore says “can’t find any time machine backup” after selecting the right nas drive and a migration assistant stays “connecting” forever.

Trying to access directly the drive allows me to acces the mybookliveduo unti but not the mybookliveduo-backup where I suppose the backup.mdbackup file is stored.

I tried also to contact the support via email describing in depth the problem. The answer was: try to access it, if you don’t succeed, reset it. Vaya con Dios in other words.

I’m really, really afraid for the purchase I made, I lost everything and the only good thing is I was using iTunes Match so my huge MP3 collection isn’t lost.