Cannot remotely access EX4100 thru

I’ve tried several times to access my EX4100 via When I try, I get an error message "Cannot Connect to WDMyCloudEX4100. When I try to accept the security certificate as suggested by the error screen, I get a message
“The connection has timed out
The server at is taking too long to respond.
The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.”

I tried two different browsers and got the same error.


Please check the Supported WD Drives with WD2Go™ Cloud application:

WD2Go™ Cloud currently supports the My Passport, My Passport for Mac, and My Book drives purchased from a Best Buy store only.

My Passport Family

WD device Model numbers that begin with
My Passport Ultra WDBFKT, WDBTLG
My Passport for Mac WDBP6A

My Book Family

WD device Model numbers that begin with

WD easystore

WD device Model numbers that begin with
WD easystore Desktop WDBCKA*

@GleasonFan, For remote access, please refer to this link: My Cloud OS 5: Remote Dashboard Access

Yay! Got it resolved. You pointed me to a couple locations I hadn’t checked previously. THANK YOU!


1 Like