Cannot register to MioNet


I have My Book World II (white light), but it fails to be visible through MioNet. In the MBW admin page I can see the MioNet status “Started / Unregistered”. I have created an account in MioNet… I login to MioNet Web access… it detects MBW, ask for registration (with a default name “WDStorage”), but that’s all. If I click OK I get “registration failed” after a while… MioNet Web/My Resources is still empty, MBW still has the status “Started / Unregistered”. In my router I tried to forward ports 22, 80, 443, 445 to MBW, but it does not help. What should I do?


Try to select the reset option and then install the Windows client from Mionet, it tends to work.

Go there and restore Mionet:

Page has specific instructions depending on your model and your system.

I experimented a similar issue and this fixed it.

Try to stay away from the Mionet Windows client unless you intend to share your computer and control it remotely through Mionet. Once Mionet Windows client is installed and you want to remove it, it’s a pain to also remove your computer from Mionet. Using the Mionet web interface instead is clean (no implicit computer registration or whatever).

Also, you don’t need to forward any port with your router. All mine are in stealth mode and Mionet works like a charm. Don’t open your network for potential hackers to sneak in.

Let me know of the outcomes.

If this worked, please mark as solved and click the star to grant me kudos.

I’ve the same problem, but this can’t help. Everytime when it asked to register my WD - answer is “registration failed”

Can anybody help me?