Cannot logon to individual accounts after update to OS5

I just installed OS5 on my UltraEX2 and now cannot log into individual accounts using the Mac Safari browser. Log in attempts are greeted with an “incorrect credentials” error.

I was able to log onto the individual user accounts using the user ID and password connecting with Time Machine on the Mac, so am able to back up my laptop. But I would really like to be able logon to the UltraEX2 with the browser.

Any suggestions?


Please check the following article for solution.

KBA 29448 My Cloud OS 5: How to Add Users and Enable Remote Access

These were accounts that were established in OS3 and migrated to OS5 following the instructions displayed after the OS5 update.

Are you saying that I need to delete the migrated accounts and then create new ones for OS5?


Check the Cloud tab and make sure the ‘admin’ user is signed in and existing users have email addresses associated with them. Users should have received an email invitation in which they must click on “Create Account” or “Login” (depending on their status) to associate to the OS 5 Cloud Server.

walgreenslistens Wrote:

Did you have a fix on this issue? Facing same issue but no response from anyone and couldn’t find this topic troubleshooting in google.

For OS5 you need create new account

Thanks for the tip - that’ll work for me since it’s a family of 4, not too complicated for people to handle.

BUT, I actually want to change the email address on the Admin account - any ideas about what the process is for that ? Don’t really want to delete the admin account … Please don’t say re-initiate the entire device from scratch …

Emails are associated with each account. Checked spouse’s email and she has not received an invite, just a promotional email from WD…

During the update to OS5 I entered new passwords for all users as instructed. Disappointing that the update does not go smoothly.


Update on my “issue”: in reality, I simply needed to read the first solution provided by SBrown more closely.

The email for the admin account was carried forward with the OS3 to OS5 migration, however the email is on the “Cloud Access” tab of the user interface, not on the “Users” tab… Once the support team cleared that up for me I simply deleted the email from the admin and then added the new email I wanted.

While there I found that all of the other user accounts had had their email removed during the migration (which I did quite a few months ago…)

As a side note, the email address found on WD Support (associated to the SN of your device) needs to be maintained by the WD Support staff, it is not something you can modify in the self-service side of My Account paramters…

I signed in as admin to my MyCloudEX2Ultra and made sure that admin is signed in under the Cloud Access tab. But I still cannot log in as a user through my web browser connecting locally to the MyCloudEX2Ultra. I can log in through the

As admin I created a new user account. Tried logging in to the new account connecting locally using my browser and received an “incorrect credentials” error. I then enabled cloud access for the new account under the Cloud Access Tab. Received the email invitation, clicked the link and established the account. Can log into the account using but still get an “incorrect credentials” error when I try to log in using a local connection to the MyCloud server using my web browser.

Finally, I tried to connect to the new account using the Mac’s Finder to access the server and log into the new account, but receive a log in error. The password is not recognized.

I don’t understand why this is happening. Never had this problem until I upgraded to OS5. In OS3 any user account created could log into the MyCloudEX2Ultra locally. In OS5 admin is the only user that can log in with a browser through the local network connection. No one else can.


Finally connected to the EX2Ultra through finder for the individual user accounts. But still can only access the admin account over the local web connection. Is this a feature, that only admin can connect via browser through the local network that the EX2Ultra is on?


Only the admin account can access the dashboard.