Cannot install OS on WD15EARX SATA/64MB Cache HDD

Can anyone help me. I have a WD 1.5 TB HDD 7 month old. and recently I am unable to install Windows on it. I have tried XP, 7 and 8 but no luck. But when i tried Acronis Disc director I can view my all Files stored in HDD and also i have formated the system drive via Acronis. but still unable to install Windows OS on it. Please suggest me any way so i can use the HDD and get back my 

try running wd Data lifeguard diagnostics. Run the Extended test. you may have a bad sector(s). I am wondering why you want to install Windows 7 on a green drive. They are not optimized for it.  If you need a good everday drive. WD has a blue version. WD10EZEX. Unfortunatley they only go up to 1 TB.

Its a WD Black, recently i met an windows error booting and so trying to reinstall os. I tried to boot with Hitachi 500GB HDD but it is failed to boot with this WD HDD attached. Only way i can see the files and folder in WD by Acronis Disc Director.

Here I have attached a picture because I am confused about its green or black. Searching by model I have landed on Green Support page while if i go through colourthen Its Black


I got the same model of the hard drive  from the website in the link. I were not able to install OS on it. Which later I realized that it was formatted for PC and I was installing for MAC. So I “cleaned” this hard drive through “diskpart” and it worked. Hope that helps

WD15EARX is a WD Green drive. I would do what WDFAN_69 metnioned and do a DLG Diag test on it, maybe even do a write zeros. Did you verify if your system can handle a drive that large? You may need to check the computer/motherboard manufacturer to see how large of a drive the system can support. I would also check the BIOS and make sure that the drive is properly detected in there and possibly change the SATA port settings to something like AHCI or IDE depending on what options you have.

My MB is capable to run 1.5TB running on Intel i3 and 4 gb ram…also i was running this HDD on my PC. but as i am  out of my home so cannot give u my configuration… shortly i will try n will give feedback… Any way kudos for your help