Cannot get Sleep Function to Work on WD500 Black PCIe M.2 SSD Win 10


#1

I had no problem installing Windows 10 on a PCIe WD500gb Black M.2 SSD; however, ran into a brick wall trying to get the Sleep function to work. Tried all solutions available on web.
What intrigues me is that people had same problem with their Samsung PCie installed M.2 SSD. Samsung solved that Sleep problem by providing a driver to use instead of the MS auto installed PCIe M.2 SSD driver.
I don’t see any WD PCIe Nvme M.2 SSD driver on the WD website for downloading; rather do see information that claims the MS PCIe Nvme M.2 SSD Windows 10 driver is good enough.
Any suggestions would be truly appreciated.
All other Windows 10 functions work fine, just no sleep. What does happen when sleep is initiated is the OS appears to go into sleep, but when using mouse or keyboard to wake, the OS start to awake, but there is no mouse or keyboard; only the windows initial screen. Must hit restart key to reboot or the shut down system key to reboot. Then all works fine again, except sleep. Just a reminder, I have already tried all of the regular solutions like turn on / off hibernate, turn on / off PCIe power / minimize / maximize power, etc.


#2

All right. My inquiry has been up for several days now and there is no response. I doubt that I did not explain the problem clearly.

No thanks go to the non-responders that could have helped me.

Anyway, for others that run into the same problem I have with this M.2 drive and enabling the sleep function to work on Windows 10, I have found the solution on my own.

I went into the bios and change the SSD to IRST. After doing so, Windows 10 now goes to sleep and awakens without a problem