Cannot find the specified path (HRESULT: 0x80070003)

I am running SmartWare 2.4.16 on a Windows 10 system. Everything has been working find, but today I find that I cannot backup. I keep getting a result like “Cannot find the specified path” when I click Backup manually, and my entire backup directory is gone.

I’ve tried rebooting, reinstalling, running sfc and dism to check for image issues in the OS.

Is this a known problem, and is there a fix?

Since you have tried reinstalling the app and ensuring your system is error-free then perhaps it would be best to send an E-mail to WD Support about this for an investigation. You can do so in the following link:

Try to provide as many details as possible related to the issue at hand alongside what you have tried so far. They may contact you if they need additional information.

Are you having any problems with your My Cloud. Does it show up in your network? If you have the Desktop app is it working?

_This must be a problem on WD’s end. Mine is acting up too. After opening it and everything appearing on the Home tab as soon as I open the Backup tab my SmartWare disappears. The same as yours shows up,
Cannot find the specified path (HRESULT: 0x80070003) _

Here is what I did and my SmartWare is working again. I right clicked on Start then clicked on Control Panel>Programs>Uninstall a Program and chose WD SmartWare and at the top selected Repair. After this completed I rebooted my computer and now my SmartWare is working again.

I don’t know if all this was necessary or not but it worked. See image below. Click on, tap or activate image to enlarge it.

1 Like

Worked for me just now. Thanks

I solve like this:

Delete Temp files (don’t know if needed but I do it first when fix):
C:\Windows\Temp
Delete all the files you find there, some files could not be deleted… don’t worry.

step2:
Go to WD Smartware, Backup, (Advanced View) this is a arrow down , I untick “mail”, apply.
And start to work again… I put again “mail” and still working good.
Then when you go to “view Files” (when the problem say : The system cannot find the specified path) now say: File pending backup. So it works!
Hope help!