Cannot Find MyBookLive on Network

Hi guys,  I need some help.  My 3TB MyBookLive has been working perfectly as my media storage for about 10 months.  Here’s the sequence of events that happened yesterday:

  • It was running really slowly and buffering and I noticed my internet activity was high so I disconnected the modem.  I then managed to successfully watch a TV show from the MyBookLive without any trouble.

  • I then reset my router as I had forgotten the password and reconfigured the wireless network (figured someone had hijacked it)

  • For a moment under the new reset router network I access the MyBookLive public folder and could browse my music and tv show folders but the movies folder was listed only as an unknown file named “Movies”.  At this point I started fearing that my data was gone.

  • I unplugged the MyBookLive and let it boot up again.  Since then, I’ve never been able to find it on the network.  I’ve tried standard Windows Explorer, typing the i.p. address in the manual in a browser and WD Link.  Nothing finds it.

  • The LED light on the front is constant blue with a flash of yellow periodically.  It’s not a constant yellow flash, there is quite a bit of time of solid blue between each yellow flash.

So here I am, perplexed and stressed that my drive has failed and I’ve lost all my data.  Can anyone help?


Try pressing the reset button on the back of the my book for 4 seconds. If that doesn’t work you might need to replace it.

I tried that already.  Same thing with the blue solid LED and intermittent yellow flash.

Is there any way to recover the data if I do need to replace it?

I also have a 3TB WD My Book Live - configured via 4 Port Router.

    There is a 1TB WD My Book Live also on the same Router.

The 3TB worked fine up to recently on my network - 1 x XP, 1 x Windows 7, 2 x Laptops using Vista.

Then, no LEDS on both drives after a Firmware update.

Then, no recognition of the 3TB drive.

The network LEDS on both WD kit and the Router are exactly as I would expect - one flashing, one steady both green  - so there is a connection and the hardware is working.

I am an experienced user - I’ve check all firewall issues, I swopped cables over, I tried the 4 sec reset.

Now come on WD you must know what this is about - there are so many posts - please give me some idea how to fix this one !

Why did it work for 6 months then stop after a firmware update ???

It goes back to the store for a refund if I don’t resolve the issue - please help !!