Cannot find My Cloud drive. My Cloud IP address is not in my router range


I just bought My Cloud USB3.0 4TB last Friday. I could configure and use it prior to today.

Today I could not find the device in my router ip range ( so I decided to reboot my router and reset My Cloud drive (4 seconds reset). After the drive finished rebooting, the LED status was blue. I try to check the router’s DHCP clients again but still could not find my drive. Then, I check the ARP table and found that my drive was mapped to another ip address that is out of my router’s range ( in the picture).

I could log on to Twonky using Firefox but cannot access my local cloud.
Can anyone help me to resolve this issue?


169.x.x.x address means DHCP hasn’t been able to allocate an address.

Once you have sorted that out, use your router to set an infinite lease timeout for the IP address DHCP has allocated.

Did you allow each of these devices to reboot before resetting the other? i.e. don’t reset them at the same time.

I suspect another router reset should sort the problem; resetting the MyCloud will force it back to using DHCP to get an IP address.

Hi cpt_paranoia,

Thanks very much for your reply. My problem has been solved.

I tried (in sequence): unplugging the LAN cable, rebooting the router, plugging in the LAN cable, rebooting the drive.

Finally, I got my drive a valid ip address.