Cannot expand folders on USB drive

Using 4TB Passport WD drive. Win 10 x 64 version 1909

This problem has just appeared in the past week.

PC starts normally, Dell logo, home screen, key in password and desktop comes up.

  1. Attach USB drive (E:). I run a daily backup and System Image

Folders shown on the drive are File History, Myname-PC, WD Software Installer, Windows Image Backup and a Family History application Backup. All can be expanded and contents seen.

  1. A schedule backup is run and the folders named Myname-PC which is my complete back up and Windows Image Backup cannot be expanded. All the others can be expanded and contents seen.

  2. Safely remove USB drive, leave for 10 minutes and re-attach but the two folders still cannot be expanded.

  3. Tried a different USB port but still cannot expand the folders named above.

  4. Safely remove USB drive, restart PC which advises to wait (Blue screen with spinning circle of dots).

After several minutes Dell logo appears and can start PC with password.

  1. Connect USB drive and all Folders can be expanded and contents viewed. After the backup is run I have to go through items 3, 4 and 5 every time before I can see the contents of the folders as described.

Drive (C ) in File Explorer

View>Options>Change folders and Search options>view> Show hidden files, folders and drives is selected.

Hide protected operating system files (recommended) is ticked.

Drive (E ) USB in File Explorer

View>Options>Change folders and Search options>view> Show hidden files, folders and drives is selected.

Hide protected operating system files (recommended) is ticked.

This has never occurred before. Can anyone advise how to fix this.

Tom Gray

Tom…I see you’ve been here since jun23…and nothing…so any success in opening the folders. I’ve recently been poking around this Passport Drive, trying to Explorer view the files and folders and even the total free space… I’ve made some comments in other postings… How to delete old backups to free up space on WD Passport

This one had to do about freeing up space…
I looked again at my Passport 1T backup. the main one that contains that single scheduled backup folder is “WD Backup.swstor” This finally expands to a History and a Volume(,…) folders. History has all the backup old copies based on date modification. Files have appended names and _LAST added as pointer. The Volume() contain that latest copy in true name and size.

So, are you still saying the you cannot Expand the folders by double clicking the folder? Curious. On another note, do you back up everything under you name, or just selected Necessary folders. I found my drive space slowly getting chewed up… I see you have a 4TB monster.

Hello HowAboutMe,

My situation is still the same.

I did have a response from Jonty. S of WD Staff advising to raise it with WD support and as my WD USB is still under warranty I have raised a fault with WD on 29 Jun and have been given an Incident Ref Number but that’s as far as it has gone. No response so far.

I have no issues with space on the drive as it is a 4TB. Only using approx. 30%.

I have also been through the issue on MS Community thinking it might be a Folder/File problem which is why I included the details of the folder setting in both drives. The MS forum thought it may be due to the folders setting being “do not show hidden folder/files” so they were changed to “show hidden files/folders” but the problem persists. MS community suggested using 3rd party back up software.

I do not use the WD backup nor any Cloud backup options.

In Win 10 I use the Backup and Restore (Windows 7) to run my backups.

Using it to run a random backup allows me to view and expand the folders within the backup.

If I set a schedule, let it run and then try to expand the folders it will not allow it whether single or double click.

I then have to safely disconnect the USB, restart the laptop and reconnect the USB and I can then expand the folders in the scheduled backup I have just run.

If I miss out the restart it will not allow the folders to expand.

Only the System Image folder and the MyName one which contains Files in Libraries and personal folders for all users are affected. I am the only user.

With the exception of those two folders any other folders on the USB can be expanded fully immediately after a scheduled backup has run.

I’m not sure it is a WD problem but as there was no joy from MS I am trying WD. It may not be a fault of theirs but they may know what causes it or have a solution to it. I would say it is more of a nuisance than a problem but still could be something that could become a bigger problem.

I’ll wait and see if there is any response from WD and depending on that may try some third party software.

Thanks for your interest.

Tom.

Tom…this is interesting and detail…30% that’s almost 1.2T of data…are you backing up all the system and Windows stuff for a complete reload should the PC crash…or is that all like large movies or application stuff and not just your data for work, home, or play… I just posted under the WD External Drive Forum tab about my experience with file size… Unable to restore a file

I digress… So you use the Win Backup/Restore instead of Passport…OK.

  • you say that when you run a Scheduled backup the certain folders cannot be opened. You mention that a Random (forced rather than scheduled) backup does allow opening?
  • if you rt mouse the folder and Open or Open in a New Window also not work?
  • if so, my guess is that the Backup/Restore program is still got your 4TB open trying to write to it. Forcing an Eject, closes the program. Why do you have to Restart the laptop, can you not just re-plug it in and have the PC recognize the USB?
  • since you are online when your backup (or do you leave your PC on and schedule after-hours backup)…sound like the USB just locks up after a backup. Is it possible to open a Task Manager App window and check if there is a process for the Backup/Restore program running under Apps…If so, maybe you could End Task on the bottom. Type Task Manager in the lower left tool bar Search box or magnifying icon. I store a quick link to this on my lower tool bar for quick execute. If you don’t see it under Apps, scroll down the page too.

This issue is more of a nuisance than a problem. I have overcome it by changing the scheduled back up to just before I shut the PC down at the end of the day. Next time I start up I can expand all the folders. This means I don’t have to restart if I want to expand the two folders in question.

Not how it should work and it may be something that could become a bigger problem later but for the moment solves my problem.

It is unlikely to be a WD problem because all other folders on the USB can be expanded. Only under specific circumstances the two named ones cannot be expanded. Also no one else in the WD community seems to have encountered this issue. As there was no joy from MS I am trying WD. It may not be a fault of theirs but they may know what causes it or have a solution to it.

Many of the responses on the MS community suggested using 3rd party back up software as the Win 7 option within Win 10 is failing and is going to be phased out. As Win 7 is still used and supported by MS I’m not sure about that. I’ll wait and see if there is any response from WD and depending on that will try some third party software.

As far as my USB storage goes I just checked the USB and it is 1.1TB of data. That figure is misleading as I keep the last three backups of several programmes I use. The Backup & Restore Win 7 option does a full backup of files in Libraries and personal folders on Day1 and incremental changes on days 2 to 7. It then repeats the cycle and will continue like that until there is no room left. I go in periodically and delete all but the last three. There were 10 and I have just deleted 7 of them.

If you are having storage space problems and you use the Win 10 File history I would check the settings. Every time a file is altered File History makes a new copy or version of it.
The default setting to retain backups is “forever” but can be reduced down to one month.

There are a couple of separate issues that may be connected with the USB issue.

In Windows Update I get an advisory warning that the May Ver. 2004 is coming but my Device is not quite ready yet but I need do nothing and it will show in Windows update when ready.
I think this may be because of the age of my PC (7 years).

The other issue was caused by a MS Update of an Intel SCSIAdapter 17.5.3.1026 driver update and as I understand it is connected to the Windows update of Ver 2004 problem and is being looked at by MS and Intel and possibly the OEM (Dell in my case).

My work around of changing the schedule has resolved the USB issue for me in the meantime but if I get any response from WD I will post it here.

Tom

Tom…interesting reading…at least you go into detail and like to type…I like reading expanded readings rather than short bursts…

Went back earlier, and sorry…I missed the fact you were using a WD device, but running the Win Backup/Restore…or the newer FileHistory utility. Not familiar with this, but did I read that it backs up all the Windows folders and that you cannot change or add your own folders…I was wondering why you have 1.1TB of stored date on the 4T drive.

I noticed my drive was creeping up when using the Passport Backup…so I download the free Treesize pgm, and found I had many Mozilla cache2 files being backed up. I’m almost done deleting over 2.5millon files of cache pointers under the AppData/Mozilla. Get a program like this and check the sizes of your folders/files…you will be surprised.

Your method of Shut down after backup schedule works. However, can you not just pick the USB drive in Explorer, rt click to eject (may not see the drive…) and just re-plug the device back into the PC without having to do a complete Restart. I thought USB drives are Plug/Play type devices unlike the old serial port type…I think I read you are still on Win7?

Hello HowAboutMe,

Thanks, I am not very technical so tend to go into detail to make sure I’ve explained things as best I can. As for typing I’m a one finger man.

I have used Win 10 for some time now, having taken the free upgrade from Win 7. File History is the backup for Win 10. MS also included Backup Restore (Windows 7) so that it can be used for those upgrading from Win 7 (which in my opinion was the better system) or restoring from old Win 7 Backups.

As far as the amount of stored data (1.1TB) that is now 551 GB and I still have some duplicate backups of approximately 210 GB to delete.

The Backup & Restore Win 7 option does a full backup of files in Libraries and personal folders on Day1 and incremental changes on days 2 to 7. It then repeats the cycle and will continue like that until there is no room left on the target storage (in this case my USB drive). I go in periodically and delete all but the last three. Currently there are 10 Win 7 backups and deleting 7 will account for the 210 GB mentioned above.

File History as far as I can tell backs up everything including the Recycle Bin but it does not make a System Image which is why I use the Backup & Restore (Win 7) option. File History is switched on by default and if the default settings that I mentioned before are being used it will very quickly consume storage space.

Right clicking on the USB drive in Explorer does not give an option to eject. At the bottom right of the task bar there is an upward arrow which if you click on it has an option to safely remove hardware and eject media. I have used that and then reconnected the drive but the folders in question still will not expand.

I am pretty certain this is an MS issue and over the years the monthly update from them has often caused all sorts of minor but very annoying issues for some but not all users. The following months update usually fixes them.
I get the update in the second week of the month so I hope this issue will be fixed with the July one.

Not heard anything from WD and don’t think I will.

Tom

Tom… very interesting insight to the B&S backup…you get a full + 6day incremental that recycles every week. Wow, must keep you busy in deleting past weekly folders. I reduced my backup space, while using the Passport backup to only files that I really thought I didn’t want to loose. Unfortunately, a system crash would require me to completely reload everything, including hardwares and applications…I keep copies of such in my download and desktop folders. Also bookmarks from Mozilla and images from Snagit. Storing other download movie folders are done directly to the external HD.

I’m glad you do a safe eject of the USB… there was an issue with un-safe ejection that I added my comments here… My WD elements is not accessible - freezes file explorer

Users USB attached drive corrupts the Explorer when plugged in. User was told USB was in use, when trying to eject, but could not find it, so he pulled the plug. I had a similar problem but to a file on my internal drive. I tried to delete a file that had an open Movie window open but was minimized. Forced multiple deletes…never could. Subsequent touch of the file screws up the Explorer…I have to Restart PC. Bottom line, if a file is in use in an application or a external HD is being used by the PC, care must be used when performing tasks to that item. I too notice that certain USB’s do not have rt mouse ejects, but do in the lower rt up wedge of the task bar.

I really hope that the monthly MS updates fixes your issue…because the problem happened after a Sys update, maybe… sounds like the B&R backup is not releasing the open HD. I don’t know if you can see some process still running under the PC’s Task Manager utility. I keep a shortcut to TM on my lower tray…constantly looking a Processes and Ethernet transfer speed…please update when you get fixed.

Hello How About Me,

A very helpful lady called Hermione from WD gave me instructions on how to download and run software that would check the WD USB drive. After doing so the drive passed with no faults found so it can be ruled out as a possible cause.
Since I last posted I have had three updates from MS including the upgrade to V 2004. At first this seemed to resolve the issue but after several days it has occurred again. It only happens now and again.
Consensus of opinion from MS Community is that the Backup & Restore (Windows 7) which is included with Win 10 is to be discontinued as there are several issues with it. I cannot vouch for the validity of that. Several instances recommend using third party back up software instead of the Win 10 option. I am currently using a 30 free option of EaseUs which so far seems to be doing ok.
As the WD USB drive is eliminated this thread can be closed.
Thanks for your interest in this issue.

TomGray

Tom…nice to see some resolution for you…even if MS is removing Backup&Restore option. I’m not familiar with many Backup…currently using the WD Backup…knock on wood, with only one issues so far!

  • you said that Hermione gave you instructions for checking the WD USB drive…was that the WD Drive Utilities?
  • You also said that the “USB drive is eliminated” you mean you’ve eliminated the WD drive as a problem, since it was a backup software issue.
  • a couple of days ago I commented in a thread about Safe Eject of a WD USB, using the icon by the clock. User had an issue that he could not shut down without logging off because an software was using the drive…since I think you troll this Forum, I’m sure you saw this…if not, here it is…My passport won't shut down properly. Help please
  • changing the USB to use the Safe Eject was done in the Device Manager, to Better Performance from Quick made my removal Work.