Cannot drag and drop files from macbook to live hub


#1

im having a  problem copying files from macbook to live hub. When i try to click and drag a movie into the live hub i get an error saying "the item cant be moved because ‘wdtvlivehub’ cant be modified. I just upgraded to snow leopard and never had this problem when i was runnin 10.4.11. Please help!


#2

Everybody seems to get a different error, but I think the problem is the same.  Unfortunately, in order to try the solution that worked for me, you’ll need to open a terminal.  I know, not terribly Mac-like.

In the Finder,  search for ‘terminal’, which will probablly show up torward the bottom of the list of stuff that turns up.

In the terminal, type:

   sudo chmod -R 777 /Volumes/WDTVLiveHub

and hit enter.   You’ll be asked for your password (I think).  The good news is that this should allow you to copy files into your LiveHub.  The bad news is that you’ll have to do this every time you connect to it.

Hope this helps!


#3

No luck… Still get the same thing. Thinking of maybe just going back to tiger as it didnt seem to have a problem dragging and dropping with that! Unless you have any other ideas???


#4

I have almost never used a Mac.  Last night, I had a few minutes to try and connect, but did not figure out how.  The Mac is my daughter’s and she’s too busy with school right now for me to get much time.  It did make me wonder if you were using the ‘iTunes Server’ function, or the Windows smb networking to connect?

I wanted to check the ownership and permissions of the mountpoint when the LiveHub is connected, but you can do that at your end.  When you are connected, and start a terminal, if you ran the command:

    ls -l /Volumes 

(case counts, so you have to use lowercase, but in uppercase for readability LS -L is the first bit) in the output you should see a line like (doing this from memory, so I’ll probably get a few things wrong):

  drwxr-xr-t   root  admin   4096    WDTVLiveHub

The first two parts are the most interesting:  ‘drwx…’ and the ‘root admin’ since these control who gets to read, write and execute files in the folder.  When we made a Windows smb connection to our LiveHub, the permissions were rwx-w–w- which meant that a regular user could write files to the device, but not read them.  Since you have to be able to read files even to get a directory listing, these permissions are useless for a real folder.  I’m very curious about why the command above, which sets them to rwxrwxrwx did not work for you. 

What version of Snow Leopard are you running?  We have 10.6.3 here.  I understand Apple is up to 10.6.6 at this time.  Since 10.4.x worked fine, and 10.6.x doesn’t, Apple must have made some kind of change to the process that mounts devices in the file system between those releases.