Cannot download wd2go app on Nexus 7

Bought a new Nexus 7 with Android version 4.1. Succesfully downloaded the wd2go app. Everything seemed ok, but was having some problems with streaming. Meanwhile downloaded Android version4.2 when prompted, and wd2go app worked as before.

However after deciding to start again and  having uninstalled the wd2go app, I cannot reload it.

I get a “your device is incompatible with this version” message

Anybody got a solution?


Hi and welcome to the WD community.

You can try power cycling your device and then try again. Also be sure that the WD2Go app is not stuck in the applications list (Setting/Applications).

1 Like

Hi Ichigo,

Thanks for your response.

I omitted to say in my request that when I deleted the wd2go app from my Nexus, that it also disappeared from the app play store on the tablet itself.

The wd2go app I was trying to use after, was from the android app store on line. I had previously powered  up the tablet on numerous occasions, without success, and even returned to the shop with it. The tech there confirmed that the app was missing from the google play store on the device. He also could not reload the app from the on line store. His advice was to wait awhile and see if it reloaded. 

I tried the tablet  for the first time yesterday. The wd2go app was back on the google play store listing. I successfully reinstalled it and am now up and running.

Still puzzled why it removed from the play store listings???

Best regards Greenie